Bug 121797 - gnome volume applet does not control audio
gnome volume applet does not control audio
Status: CLOSED DUPLICATE of bug 121376
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-27 17:36 EDT by Mark Rush
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Rush 2004-04-27 17:36:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
Onboard AD1985 codec on Asus P4C800-E Deluxe motherboard.  Identified
by system (Soundcard Detection) as Intel 82801EB/ER (ICH5/ICH5R) AC'97
Audio Controller.

First boot, system audio starts out at 0.  Gnome volume control applet
"lever" may be raised or lowered, but has no effect on audio.  When
volume lever is raised, once released the lever slides by itself back
to 0.

Normal volume control may be achieved using the Analog Devices AD1985
tab of the menu item Sound and Video>Volume Control.  Attempting to
use the volume controls on the Intel ICH5 tab kills the audio.

Volume control applet worked fine under test2.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Attempt to affect audio volume by raising or lowering applet lever.
2.
3.
    

Actual Results:  No change in audio.

Expected Results:  Audio should have gotten louder or softer.

Additional info:
Comment 1 Mark Rush 2004-04-28 10:27:21 EDT
After updating all packages from up2date on 4-27-04, now I am getting
normal volume control from gnome volume control, both tabs.  Using the
panel's volume control applet affects volume, but once released the
slider slowly slides by itself down to 0.
Comment 2 Genadi Enchev 2004-04-30 11:47:13 EDT
I have a similar problem with the applet also. At first everything
seems normal. However, when I mute the sound and try to log-off, the
regular sounds are coming out of my speakers. I tried several times to
fix it, but unfortunately I couldn't. 
Comment 3 Mark Rush 2004-05-06 18:35:35 EDT
After fresh reinstall of test3, gnome panel volume control applet
functions normally, all other mixer functions are also normal.  The
only thing I did differently this time is install kde alongside gnome.
Comment 4 Mike Becker 2004-05-09 10:41:35 EDT
Did a fresh install of T3 on a Gateway M500...while the sould does
work with the various multimedia apps, the gnome system sounds do not
work.  Yes!  I do have things enabled under preferences/sound as well
as having installed the gnome-audio-extra package...
Comment 5 Brian "netdragon" Bober 2004-05-09 16:52:06 EDT
I have KDE installed alongside Gnome and I have the slider sliding
back down issue. It doesn't slide back down if you stick it at 100%.
Comment 6 Brian "netdragon" Bober 2004-05-09 16:52:26 EDT
By the way, I'm fully up to date, and the issue has not gone away.
Comment 7 Mike Becker 2004-05-21 09:47:25 EDT
Right now the general release of FC2 has been out for a couple of days
and I did a clean install.  The sound worked well from the start
except for the system sounds.  I used gnomemeeting and xine (Dag's)
with no trouble at all.  Gnome's applet slider is back to working
normally, the mixers too all work as expected.  But no system
sounds...and yes, I did install the gnome-audio-extra package.

However, today, May 21st, there was an update for libgnome and
libgnome-devel.  Once I updated these packages the system sounds
started to work!

FYI - the system here is a Gateway M500 laptop...

Thank you for all of your work!
Comment 8 Brian "netdragon" Bober 2004-05-21 19:48:14 EDT
The slider works properly for me too on FC2.
Comment 9 Clint Harshaw 2004-07-17 00:43:29 EDT
I've just installed FC2 as a fresh install, and performed all updates.
The volume slider on the Gnome panel slides down as described above.
The only way to prevent it from sliding down to 0 is to slide it all
the way to maximum volume.

I have opened the full volume control and moved several sliders up,
but that had no effect on the volume slider slipping down on the panel.
Comment 10 Alexandre Oliva 2004-07-19 01:12:22 EDT
I get the impression that I only run into the problem if I start an
application that is supposed to produce sound *before* I change the
sound controls.  If I try to change the volume after the application
starts, it feels like the application that has the sound channel open
tries to restore the volume it had when it started.  Just got this on
FC3test1+updates.
Comment 11 Mark McLoughlin 2004-07-19 10:28:41 EDT

*** This bug has been marked as a duplicate of 121376 ***
Comment 12 Red Hat Bugzilla 2006-02-21 14:02:48 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.