Bug 121798 - Installer crashes when creating and initializing partitions
Installer crashes when creating and initializing partitions
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-27 17:40 EDT by Jaak Simm
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 15:34:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Traceback of the crash, saved into a floppy. (656.30 KB, text/plain)
2004-04-27 17:42 EDT, Jaak Simm
no flags Details

  None (edit)
Description Jaak Simm 2004-04-27 17:40:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
Firstly, the installer gives the famous "Unable to align partitions
correctly..." warning. This may be the cause of the bug.

The install crashes when formating and initializing partitions.
Prompts python traceback, which I saved on my floppy and then asks for
reboot.

I have just one ide Maxtor 80GB (ATA), with following partitions
before installation:
- 60gb NTFS (in the beginning of partition)
- then 10gb logical partition with FAT32 and empty space for swap
- empty space (10gb)

Partition selected during installation:
1) Created swap of 1G into the logical partition, placed into the
freespace after FAT32
2) /boot of 100MB in the beginning of the empty space (primary partition)
3) / fills the end of the drive (primary partition)


Here is the traceback:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 1044, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 242, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 763, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 169, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 237, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 669, in doPreInstall
    method.mergeFullHeaders(id.grpset.hdrlist)
  File "/usr/lib/anaconda/harddrive.py", line 172, in mergeFullHeaders
    self.mountMedia(1)
  File "/usr/lib/anaconda/harddrive.py", line 52, in mountMedia
    self.mountDirectory()
  File "/usr/lib/anaconda/harddrive.py", line 90, in mountDirectory
    readOnly = 1);
  File "/usr/lib/anaconda/isys.py", line 173, in mount
    rc = _isys.mount(fstype, device, location, readOnly, bindMount,
remount)
SystemError: (22, 'Invalid argument')


Version-Release number of selected component (if applicable):
Fedora2-test3 isos (i386)

How reproducible:
Didn't try


Additional info:

After the install, my computer booted to windows and hda5 was there,
but without any data. It seems the partition table was somehow damaged.
Comment 1 Jaak Simm 2004-04-27 17:42:50 EDT
Created attachment 99728 [details]
Traceback of the crash, saved into a floppy.
Comment 2 Jeremy Katz 2004-09-22 15:34:36 EDT
Should be happier now.

Note You need to log in before you can comment on or make changes to this bug.