Bug 1217987 - docker push to dockerhub does not work (docker 1.16)
Summary: docker push to dockerhub does not work (docker 1.16)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: docker-io
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ivan Chavero
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1218639
TreeView+ depends on / blocked
 
Reported: 2015-05-03 21:07 UTC by Steven Citron-Pousty
Modified: 2015-07-29 01:42 UTC (History)
19 users (show)

Fixed In Version: docker-io-1.6.2-3.gitc3ca5bb.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1218639 (view as bug list)
Environment:
Last Closed: 2015-05-22 19:53:58 UTC
Type: Bug


Attachments (Terms of Use)

Description Steven Citron-Pousty 2015-05-03 21:07:10 UTC
Description of problem:

I can build and tag a docker image on my local machine but I can not push it to dockerhub. I am sure I have a dockerhub account and I can push with F20 and docker 15. Maceij can push with Ubuntu and Docker 16. 


Version-Release number of selected component (if applicable):
Docker version 1.6.0, build 3eac457/1.6.0


How reproducible:
Always

Steps to Reproduce:
1. Make a local docker image
2. Tag it
3. Try to push it to dockerhub

Actual results:

$ sudo docker build -t thesteve0/openshift-qpid:latest .
Sending build context to Docker daemon 2.048 kB
Sending build context to Docker daemon 
Step 0 : FROM fedora/qpid
 ---> 6b45d8271e13
Step 1 : MAINTAINER spousty <spousty@redhat.com>
 ---> Using cache
 ---> 32b450b8f57a
Step 2 : ENV IMAGE_DESCRIPTION QPID C++ AMQP Server 0.30.3
 ---> Using cache
 ---> 03be2f186029
Step 3 : ENV IMAGE_TAGS qpid,qpid030,
 ---> Using cache
 ---> 13797654c23f
Step 4 : ENV IMAGE_EXPOSE_SERVICES 5672:qpid
 ---> Using cache
 ---> 3a0843e1e66e
Step 5 : EXPOSE 5672
 ---> Using cache
 ---> 465c93d05637
Step 6 : ENTRYPOINT qpidd -t --auth=no
 ---> Using cache
 ---> 4ff0b3679c09
Successfully built 4ff0b3679c09


$ sudo docker images
REPOSITORY                         TAG                 IMAGE ID            CREATED             VIRTUAL SIZE
thesteve0/openshift-qpid           latest              4ff0b3679c09        2 minutes ago       607.1 MB

$ sudo docker push thesteve0/openshift-qpid:latest

Do you really want to push to public registry? [Y/n]: Y
The push refers to a repository [docker.io/thesteve0/openshift-qpid] (len: 1)
FATA[0001] Repository does not exist: docker.io/thesteve0/openshift-qpid 


Expected results:

The image should be pushed to dockerhub

Additional info:

Comment 1 Steven Citron-Pousty 2015-05-03 21:11:15 UTC
See the thread starting here for this issue hitting another user a few days ago 

https://forums.docker.com/t/docker-push-error-fata-0001-respository-does-not-exist/1309/11

Comment 2 Andy Goldstein 2015-05-04 02:14:23 UTC
The current workaround: sudo docker push docker.io/thesteve0/openshift-qpid:latest. You need to include the docker.io/ prefix when pushing to the Hub.

Comment 3 Jason Al-Mansor 2015-05-04 15:39:52 UTC
I've noticed this issue as well. I tried swapping the package binary with the binary from docker and it worked fine and it didn't display the public registry prompt.

Comment 4 Michal Minar 2015-05-05 11:24:17 UTC
Thank you Steven for reporting this. PR https://github.com/rhatdan/docker/pull/48 fixes it.

Comment 5 Fedora Update System 2015-05-05 13:58:49 UTC
docker-1.6.0-3.git9d26a07.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/docker-1.6.0-3.git9d26a07.fc22

Comment 6 Fedora Update System 2015-05-06 06:30:41 UTC
docker-io-1.6.0-5.git350a636.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/docker-io-1.6.0-5.git350a636.fc21

Comment 7 Fedora Update System 2015-05-06 19:01:55 UTC
docker-io-1.6.0-1.git350a636.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/docker-io-1.6.0-1.git350a636.fc20

Comment 8 Fedora Update System 2015-05-10 23:35:01 UTC
Package docker-1.6.0-3.git9d26a07.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing docker-1.6.0-3.git9d26a07.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-7836/docker-1.6.0-3.git9d26a07.fc22
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2015-05-22 19:53:58 UTC
docker-1.6.0-3.git9d26a07.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2015-06-02 14:21:51 UTC
docker-io-1.6.2-1.git9f4bf0a.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/docker-io-1.6.2-1.git9f4bf0a.fc21

Comment 11 Fedora Update System 2015-06-05 16:02:47 UTC
docker-io-1.6.2-3.gitc3ca5bb.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/docker-io-1.6.2-3.gitc3ca5bb.fc21

Comment 12 Fedora Update System 2015-07-29 01:42:57 UTC
docker-io-1.6.2-3.gitc3ca5bb.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.