Bug 1218002 - Disable Google Open Id option
Summary: Disable Google Open Id option
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Authentication-OpenID (Show other bugs)
(Show other bugs)
Version: 3.6
Hardware: Unspecified Unspecified
urgent
high
Target Milestone: ---
: 3.7
Assignee: Alex Eng
QA Contact: Damian Jansen
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-04 00:28 UTC by Carlos Munoz
Modified: 2015-07-22 02:20 UTC (History)
4 users (show)

Fixed In Version: 3.7.0-SNAPSHOT
Doc Type: Bug Fix
Doc Text:
Story Points: 1
Clone Of:
Environment:
Last Closed: 2015-07-22 02:20:16 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Carlos Munoz 2015-05-04 00:28:54 UTC
Description of problem:
Since Google Open Id has been decommissioned (replaced by OAuth), Zanata needs to disable this option and provide a way for users registered with Google Open Id to change.

The suggested option for this is to leave the Google Open Id login option (remove the registration one), and redirect the user to a page informing them about the changes to Google Open Id with the option to reset (or generate a new) password.

Comment 1 David Mason 2015-05-06 02:26:23 UTC
From developer team discussion:

 - When user clicks google openID, direct to a password reset page that has information about google OpenID being closed.
 - Update reset password to need only 1 of { username, email }
 - Password reset page has a link to email admin (for users who cannot remember either information)


Technical note: could make a separate page that uses the password reset page, or add a conditionally-displayed block to the main password reset page.

Comment 2 Alex Eng 2015-05-09 04:38:56 UTC
PR https://github.com/zanata/zanata-server/pull/800

Comment 3 Damian Jansen 2015-05-12 05:26:26 UTC
Verified (master) at db5c06902d28e5373af7487dcbf3db81b4716d4a


Note You need to log in before you can comment on or make changes to this bug.