Bug 121805 - athlon-smp kernel does not support >4GB of RAM
athlon-smp kernel does not support >4GB of RAM
Status: CLOSED DUPLICATE of bug 12801
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
athlon Linux
medium Severity low
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-27 19:19 EDT by Duncan Laurie
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Duncan Laurie 2004-04-27 19:19:37 EDT
In order to support between 4GB and 16GB of RAM in 32-bit mode
on an opteron system the kernel needs to be compiled with
the CONFIG_HIGHMEM64G option enabled.

From what I can gather, the -smp kernels should be compiled with
PAE + highpte support by enabling the CONFIG_HIGHMEM64G option,
which will also enable CONFIG_X86_PAE.  Then the -hugemem kernel
should support PAE + highpte + 4/4 split by enabling the
CONFIG_HIGHMEM64G and the CONFIG_X86_4G options.
(see the posting by Rik van Riel about this: http://www.redhat.
com/archives/taroon-beta-list/2003-August/msg00270.html)

Currently the i686-smp kernel has the HIGHMEM64G option enabled
while the athlon-smp kernel only has HIGHMEM4G enabled.  This means
it is possible to use the i686-smp kernel to run opteron system with
between 4GB and 16GB in 32-bit mode and use the hugemem kernel
on systems with >16GB.

However it seems that the athlon-smp kernel should also be compiled
with the CONFIG_HIGHMEM64G option so it looks and acts the same as
the i686-smp variant.

Steps to Reproduce:
1. Install >4GB RAM in an opteron system
2. Install and boot kernel-smp-2.4.21-9.0.3.EL.athlon.rpm

Actual Results:  recognized RAM is limited to 4GB
Expected Results:  all available RAM is recognized (up to 16GB)
Comment 1 Duncan Laurie 2004-04-27 19:35:31 EDT
I must have hit reload in the submit window for this to come
through twice.  Closing the dup...

*** This bug has been marked as a duplicate of 12801 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:02:48 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.