Bug 1218120 - Regression failures in tests/bugs/snapshot/bug-1162498.t
Summary: Regression failures in tests/bugs/snapshot/bug-1162498.t
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Avra Sengupta
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1163543 1218576
TreeView+ depends on / blocked
 
Reported: 2015-05-04 08:48 UTC by Avra Sengupta
Modified: 2016-06-16 12:57 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1218576 (view as bug list)
Environment:
Last Closed: 2016-06-16 12:57:38 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Avra Sengupta 2015-05-04 08:48:52 UTC
Description of problem:
Test #23 and #25 fail which happen immediately after snap restore. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2015-05-04 08:56:19 UTC
REVIEW: http://review.gluster.org/10518 (snapshot/uss: fix regression failure in bug-1162498.t) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 2 Anand Avati 2015-05-05 01:51:21 UTC
COMMIT: http://review.gluster.org/10518 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 2d3bfc6b53974c80c347d1285b6a5a7cd60d7a13
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Mon May 4 14:19:36 2015 +0530

    snapshot/uss: fix regression failure in bug-1162498.t
    
    .snaps seems to take some time, before it is available based
    on the state of the system. Using EXPECT_WITHIN instead of TEST
    to check the contents of .snaps, hence giving it some time to
    come up.
    
    Change-Id: Iac166500d5a09ba8bab00d994c27a9ad0a01b9c3
    BUG: 1218120
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/10518
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 3 Nagaprasad Sathyanarayana 2015-10-25 14:51:14 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 4 Nagaprasad Sathyanarayana 2015-10-25 14:55:01 UTC
Fix for this bug is already made in a GlusterFS release. The cloned BZ has details of the fix and the release. Hence closing this mainline BZ.

Comment 5 Niels de Vos 2016-06-16 12:57:38 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.