Bug 1218170 - [Quota] : To have a separate quota.conf file for inode quota.
Summary: [Quota] : To have a separate quota.conf file for inode quota.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard: quota
Depends On: 1190108 1202244
Blocks: qe_tracker_everglades glusterfs-3.7.0
TreeView+ depends on / blocked
 
Reported: 2015-05-04 10:57 UTC by Sachin Pandit
Modified: 2016-07-28 11:01 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1202244
Environment:
Last Closed: 2015-05-14 17:29:35 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Sachin Pandit 2015-05-04 10:57:29 UTC
+++ This bug was initially created as a clone of Bug #1202244 +++

Description of problem:
Currently we maintain the quota configuration in a file called
quota.conf which is present in /var/lib/gluster/vols/<volname>

With introduction of inode quota, we have to save the configuration
related to inode quota in a file too. If we have the same file to
service both existing quota and inode quota we might end up in the
below mentioned problem:

* quota conf is a place holder to save gfid of the directory where
  quota limit is set.
* The problem occurs when we try to remove a limit on some directory.
  As we now have two types of quota we cant distinguish between the
  type by having gfid alone.


Possible solution:
1) Currently we maintain a 16byte gfid, we can save 1 byte extra
   along with gfid that to distinguish b/w existing quota and inode quota
2) TO have a separate quota.conf file altogether for inode quotas

Version-Release number of selected component (if applicable):


How reproducible:
1/1

Steps to Reproduce:
1. Set a usage limit on directory " gluster volume quota <volname> limit-usage <directory> <size>
2. Set a inode quota limit on directory "gluster volume quota <volname> limit-objects <directory> <limit>
3. remove the limit on usage on directory
4. test the inode quota list "gluster volume quota vol1 list-objects

Actual results:
inode quota is also removed if we remove usage quota.

Expected results:
inode quota should not be effected by usage quota.

Additional info:

--- Additional comment from Anand Avati on 2015-03-16 08:07:40 EDT ---

REVIEW: http://review.gluster.org/9900 (features/quota : Have a separate conf and cksum for inode quota limits) posted (#1) for review on master by Sachin Pandit (spandit@redhat.com)

--- Additional comment from Anand Avati on 2015-04-15 09:59:33 EDT ---

REVIEW: http://review.gluster.org/10069 (quota: support for inode quotas in quota.conf) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Anand Avati on 2015-04-15 10:14:58 EDT ---

REVIEW: http://review.gluster.org/10069 (quota: support for inode quotas in quota.conf) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Anand Avati on 2015-04-15 22:20:44 EDT ---

REVIEW: http://review.gluster.org/10069 (quota: support for inode quotas in quota.conf) posted (#4) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Anand Avati on 2015-04-16 03:40:00 EDT ---

REVIEW: http://review.gluster.org/10069 (quota: support for inode quotas in quota.conf) posted (#5) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Anand Avati on 2015-04-24 02:06:00 EDT ---

REVIEW: http://review.gluster.org/10069 (quota: support for inode quota in quota.conf) posted (#6) for review on master by Sachin Pandit (spandit@redhat.com)

--- Additional comment from Anand Avati on 2015-04-24 03:12:25 EDT ---

REVIEW: http://review.gluster.org/10069 (quota: support for inode quota in quota.conf) posted (#7) for review on master by Sachin Pandit (spandit@redhat.com)

--- Additional comment from Anand Avati on 2015-04-27 01:33:41 EDT ---

REVIEW: http://review.gluster.org/10069 (quota: support for inode quota in quota.conf) posted (#8) for review on master by Sachin Pandit (spandit@redhat.com)

--- Additional comment from Anand Avati on 2015-04-27 05:34:51 EDT ---

REVIEW: http://review.gluster.org/10069 (quota: support for inode quota in quota.conf) posted (#9) for review on master by Sachin Pandit (spandit@redhat.com)

--- Additional comment from Anand Avati on 2015-04-27 11:11:43 EDT ---

REVIEW: http://review.gluster.org/10069 (quota: support for inode quota in quota.conf) posted (#10) for review on master by Sachin Pandit (spandit@redhat.com)

--- Additional comment from Anand Avati on 2015-04-28 02:35:16 EDT ---

REVIEW: http://review.gluster.org/10069 (quota: support for inode quota in quota.conf) posted (#11) for review on master by Sachin Pandit (spandit@redhat.com)

Comment 1 Anand Avati 2015-05-04 11:10:32 UTC
REVIEW: http://review.gluster.org/10524 (quota: support for inode quota in quota.conf) posted (#1) for review on release-3.7 by Sachin Pandit (spandit@redhat.com)

Comment 2 Anand Avati 2015-05-05 10:59:34 UTC
REVIEW: http://review.gluster.org/10524 (quota: support for inode quota in quota.conf) posted (#2) for review on release-3.7 by Sachin Pandit (spandit@redhat.com)

Comment 3 Anand Avati 2015-05-06 05:14:21 UTC
REVIEW: http://review.gluster.org/10524 (quota: support for inode quota in quota.conf) posted (#3) for review on release-3.7 by Sachin Pandit (spandit@redhat.com)

Comment 4 Anand Avati 2015-05-06 07:15:42 UTC
REVIEW: http://review.gluster.org/10524 (quota: support for inode quota in quota.conf) posted (#4) for review on release-3.7 by Sachin Pandit (spandit@redhat.com)

Comment 5 Anand Avati 2015-05-06 13:43:38 UTC
REVIEW: http://review.gluster.org/10524 (quota: support for inode quota in quota.conf) posted (#5) for review on release-3.7 by Sachin Pandit (spandit@redhat.com)

Comment 6 Anand Avati 2015-05-07 13:16:19 UTC
REVIEW: http://review.gluster.org/10524 (quota: support for inode quota in quota.conf) posted (#6) for review on release-3.7 by Sachin Pandit (spandit@redhat.com)

Comment 7 Anand Avati 2015-05-08 02:42:06 UTC
REVIEW: http://review.gluster.org/10524 (quota: support for inode quota in quota.conf) posted (#7) for review on release-3.7 by Sachin Pandit (spandit@redhat.com)

Comment 8 Niels de Vos 2015-05-14 17:29:35 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 9 Niels de Vos 2015-05-14 17:35:59 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 10 Niels de Vos 2015-05-14 17:38:20 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 11 Niels de Vos 2015-05-14 17:47:12 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.