Bug 121818 - python-2.2.2-config.patch is missing from SRPM
python-2.2.2-config.patch is missing from SRPM
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: python (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-28 00:52 EDT by Dave Miller
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 16:10:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Miller 2004-04-28 00:52:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.8a) Gecko/20040416 Firefox/0.8.0+

Description of problem:
The python-2.2.3-5 srpm from RHEL 3 contains a flag to set which will
build a "python2" package for RHEL 2.1 AS.  When setting that flag,
the build process referenceses python-2.2.2-config.patch, which is not
included in the SRPM, so the build fails.



Version-Release number of selected component (if applicable):
python-2.2.3-5.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. patch python.spec
1c1
< %define aspython2 0
---
> %define aspython2 1
^D
2. rpm -ba python.spec


Actual Results:  
error: File /usr/src/redhat/SOURCES/python-2.2.2-config.patch: No such
file or directory


Expected Results:  SRPM builds.

Additional info:
Comment 1 Mihai Ibanescu 2005-09-30 16:10:11 EDT
Looks like I can't find that patch anymore. At any rate it should be the same as
the config2 one, with changes to some library versions (like db) depending on
where you are trying to deploy that rpm.

Note You need to log in before you can comment on or make changes to this bug.