This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 121826 - FC2 does not run in VPC (OS/2)
FC2 does not run in VPC (OS/2)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-28 07:45 EDT by Joerg Skottke
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-08 15:54:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Errormessage on display of FC2 in VPC (OS/2) (45.99 KB, application/octet-stream)
2004-04-28 07:47 EDT, Joerg Skottke
no flags Details

  None (edit)
Description Joerg Skottke 2004-04-28 07:45:45 EDT
Description of problem:
Installing in VPC works ok but after first reboot there is a
segmentation fault that makes logging in impossible. 

Version-Release number of selected component (if applicable):
Fedora Core 2 Test 2+3


How reproducible:
Always happens when booting


Steps to Reproduce:
1. Install FC2 Test-build in VPC
2. After completed installation reboot
3. Enjoy
  
Actual results:
/etc/X11/prefdm: line 80: 291 segmentation fault unicode_start
$SYSFONT $SYSFONTACM
INIT: lx "x" respawning too fast: disabled for 5 minutes
/etc/X11/prefdm: line 80: 291 segmentation fault unicode_start
$SYSFONT $SYSFONTACM
Incorrect Linehigth 0.

Expected results:
gdm should be started, loginscreen should be displayed, logging in
should be possible


Additional info:
- this is not a dupe to issue 119838.
- Platform: VPC for OS/2 (==VPC for Windows Version 5.1)
- fc1 works w/o problems,
Comment 1 Joerg Skottke 2004-04-28 07:47:10 EDT
Created attachment 99733 [details]
Errormessage on display of FC2 in VPC (OS/2)
Comment 2 Herman Vandermolen 2004-05-15 14:34:15 EDT
- Same thing happens on Virtual PC 2004 with Windows XP as the host OS. 
- Fedora Core 1 runs fine in VPC.
- You can actually log in as root from the command line when the SEGV
occurs. When you do, you get random SEGVs on basic commands like
"cat", "file", etc. 
Comment 3 Mark McLoughlin 2004-06-04 08:00:37 EDT
Okay, I can't make any sense out of the prefdm error message - e.g.
there is no line 80 in /etc/X11/prefdm

You've also logged this against the gdm package, even though I don't
see anything immediately obvious to suggest that its a gdm problem.
You'll need to do more analysis of the problem before anyone who can't
test this on VPC can figure out a fix for whatever the problem is.

Also, you may not be seeing a single problem, but several different
ones. If you can figure out what the individual problems are and log
bugs against the appropriate packages you'll have a much better change
of getting the bugs fixed.
Comment 4 Ray Strode [halfline] 2004-11-08 15:54:46 EST
Hi Joerg,

Chances are very likely that this is a VPC bug and not a Fedora bug.
You may try upgrading VPC, or upgrading to FC3.  If neither of those
steps work, you may want to report this issue to the makers of VPC.
Comment 5 Joerg Skottke 2004-11-09 03:29:53 EST
I agree that the issue is a problem in VPC. Apparently there is
something wrong with the memory management - nothing i would be able
to debug. Probably SELinux does something VPC cannot handle.

Strange thing is that all other distros run flawlessly, no matter what
kernel is used. And since VPC has been bought by M$ there will never
ever be a fix for that.

I gues i'll better take a look at SVista instead. 

Note You need to log in before you can comment on or make changes to this bug.