Bug 1218287 - Use tiering only if all nodes are capable of it at proper version
Summary: Use tiering only if all nodes are capable of it at proper version
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: mainline
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
Assignee: Dan Lambright
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On:
Blocks: 1219600 1260923
TreeView+ depends on / blocked
 
Reported: 2015-05-04 13:53 UTC by Dan Lambright
Modified: 2016-06-16 12:58 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1219600 (view as bug list)
Environment:
Last Closed: 2016-06-16 12:58:24 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Dan Lambright 2015-05-04 13:53:43 UTC
We cannot allow tiering commands to be entered if any of the nodes involved are at a lower version number.

Comment 1 Anand Avati 2015-05-04 16:42:57 UTC
REVIEW: http://review.gluster.org/10531 (glusterd/tiering: disable tiering if cluster runs older gluster versions) posted (#1) for review on master by Dan Lambright (dlambrig@redhat.com)

Comment 2 Niels de Vos 2015-05-15 13:07:26 UTC
This change should not be in "ON_QA", the patch posted for this bug is only available in the master branch and not in a release yet. Moving back to MODIFIED until there is an beta release for the next GlusterFS version.

Comment 3 Nagaprasad Sathyanarayana 2015-10-25 15:01:46 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 4 Niels de Vos 2016-06-16 12:58:24 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.