Bug 121836 - Error activating XKB configuration.
Error activating XKB configuration.
Status: CLOSED DUPLICATE of bug 120858
Product: Fedora
Classification: Fedora
Component: redhat-config-xfree86 (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-28 10:04 EDT by Mark Ross
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark Ross 2004-04-28 10:04:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040422

Description of problem:
Error activating XKB configuration.
Probably internal X server problem.

X server version data:
The X.Org Foundation
60700000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb

[msross@viccfedora msross]$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "us", "", ""
[msross@viccfedora msross]$ gconftool-2 -R
/desktop/gnome/peripherals/keyboard/xkb
 layouts = [us]
 model = pc105
 overrideSettings = false
 options = []
[msross@viccfedora msross]$


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Every time I login
2.
3.
    

Additional info:
Comment 1 Julien Tane 2004-04-29 05:08:11 EDT
The same thing happened to me I mailed to sergey_udaltsov@pochta.ru 
 
I mailed the following infos: 
user@mymachine user]$  gconftool-2 
-R /desktop/gnome/peripherals/keyboard/xkb 
 layouts = [de  nodeadkeys] 
 model = pc105 
 overrideSettings = false 
 options = [] 
[user@mymachine user]$ xprop -root | grep XKB 
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "de", 
"nodeadkeys", "" 
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "de", "nodeadkeys", "" 
[user@mymachine user]$ 
  
 layouts = [de  nodeadkeys] 
 model = pc105 
 overrideSettings = false 
 options = [] 
  
Error activating XKB configuration. 
Probably internal X server problem. 
  
X server version data: 
The X.Org Foundation 
60700000 
  
  
  
 1386 ?        S      0:00 /usr/bin/gdm-binary -nodaemon 
 1419 ?        S      0:00 /usr/bin/gdm-binary -nodaemon 
 1420 ?        S      2:04 /usr/X11R6/bin/X :0 -audit 0 
-auth /var/gdm/:0.Xauth -nolisten tcp vt7 
 2725 pts/1    R      0:00 grep gdm 
  
ls  -l /usr/X11R6/lib/X11/xkb/rules 
 
>>-r--r--r--  1 root root    110 Apr 15 22:56 README 
>>> > -r--r--r--  1 root root   3096 Apr 15 22:56 sgi 
>>> > -r--r--r--  1 root root   2525 Apr 15 22:56 sgi.lst 
>>> > -r--r--r--  1 root root   1662 Apr 15 22:56 sun 
>>> > -r--r--r--  1 root root   1748 Apr 15 22:56 sun.lst 
>>> > lrwxrwxrwx  1 root root      4 Apr 21 16:49 xfree86 
 
-> xorg 
 
>>> > -r--r--r--  1 root root   6537 Apr 15 22:56 xorg 
>>> > -r--r--r--  1 root root   1443 Apr 15 22:56 xorg-it.lst 
>>> > -r--r--r--  1 root root   8837 Apr 15 22:56 xorg.lst 
>>> > -r--r--r--  1 root root 331727 Apr 15 22:56 xorg.xml 
 
and : 
>>su -c 'setxkbmap -rules "xfree86" -model "pc105" 
 
-layout   
 
>>> > "de(nodeadkeys)" -option ' 
>>> > Password: 
>>> > Couldn't find rules file (xfree86) 
 
And he gave me the reason: 
 
>>su -c 'setxkbmap -rules "xfree86" -model "pc105" -layout   
>>> > "de(nodeadkeys)" -option ' 
>>> > Password: 
>>> > Couldn't find rules file (xfree86) 
 
 
"_This_ is a problem! Please file the report in the 
redhat bugzilla (and send the ID to me - I'd like to 
participate). In the report, please give all the 
details you provided to me (xprop, gconf, ls, setxkbmap)." 
 
As a workaround, please check your XF86Config and 
replace XkbRules from xfree86 to xorg (and create the 
symlink from xorg.xml to xfree86.xml). Probably it will 
help gnome to start without errors. 
 
I am going to try it... 
 
 
 
Comment 2 Sergey V. Udaltsov 2004-04-29 05:53:33 EDT
It seems the symlink xfree86->xorg (in the rules directory) does not
work. Probably the absolute symlink (with the full path) would be
better...
Comment 3 Miloslav Trmac 2004-04-29 09:02:12 EDT

*** This bug has been marked as a duplicate of 120858 ***
Comment 4 Thadsana Vithaya 2004-08-27 05:27:16 EDT
I also got the xserver error message dialog all the time. The system 
was FC1 before up to FC2, the system working w/o xserver error 
message in FC1.

I notice that when update from FC1 to FC2 from update mode the 
xserver error message always come. The message is not generated when 
upgrade from FC1 to FC2 via installation mode.
Comment 5 Sergey V. Udaltsov 2004-08-27 05:47:03 EDT
Arrrrgh. This has to be put in some FAQ. After upgrade FC1->FC2,
people should either manually remove the line with XkbRules from
xorg.conf (and/or XF86Config) or replace its value with "xorg".
Comment 6 Red Hat Bugzilla 2006-02-21 14:02:49 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.