Bug 1218392 - Content View: Repository sync and content information are blank for a newly enabled repository
Summary: Content View: Repository sync and content information are blank for a newly e...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Content Views
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-04 18:57 UTC by Brad Buckingham
Modified: 2019-08-12 15:59 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:58:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 16265 0 None None None 2016-08-24 11:40:35 UTC

Description Brad Buckingham 2015-05-04 18:57:48 UTC
Description of problem:

When a user goes to add a Red Hat repository to a content view, if that repository hasn't been synced, the Last Sync, Sync State and Content are all blank.  In a previous version of Satellite 6 (6.0.8)Zack&z0us
, the user would see information like: 'Not_synced' in 'Sync Status' and '0 Packages 0 Errata' in 'Content' 

Version-Release number of selected component (if applicable):
Satellite-6.1.0-RHEL-7-20150407.1

How reproducible:
Always

Steps to Reproduce:
1. Go to: Content -> Red Hat Repositories and enable a RH repository
2. Go to: Content -> Content Views, open a content view
3. Click Yum Content -> Repositories -> Add

Actual results:
Observe that the 'Last Sync', 'Sync State' and 'Content' cells for the new repository are all blank

Expected results:
In Sat6.0.8, user had feedback like 'Not Synced' and '0 Packages 0 Errata'

Additional info:
This issue was raised by aupadhye during a Satellite 6.1 Beta test day.

Comment 1 RHEL Program Management 2015-05-04 19:03:10 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 7 Bryan Kearney 2016-07-26 15:25:24 UTC
Moving 6.2 bugs out to sat-backlog.

Comment 8 Bryan Kearney 2016-07-26 15:45:56 UTC
Moving 6.2 bugs out to sat-backlog.

Comment 10 Brad Buckingham 2016-08-24 11:40:33 UTC
Created redmine issue http://projects.theforeman.org/issues/16265 from this bug

Comment 11 Brad Buckingham 2016-09-19 13:38:31 UTC
Upstream Katello PR: https://github.com/Katello/katello/pull/6327

Comment 12 Bryan Kearney 2017-08-01 19:58:02 UTC
The fix to this bug will be delivered with release 6.3 of Satellite.


Note You need to log in before you can comment on or make changes to this bug.