Bug 1218401 - [doc] document history_list_view and set it to cmd by default
Summary: [doc] document history_list_view and set it to cmd by default
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: 22
Hardware: All All
low
low
Target Milestone: ---
Assignee: packaging-team-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-04 19:26 UTC by fednuc
Modified: 2015-08-19 07:51 UTC (History)
9 users (show)

Fixed In Version: dnf-plugins-core-0.1.10-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-15 02:13:30 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1235901 None None None Never

Description fednuc 2015-05-04 19:26:17 UTC
Description of problem:

dnf history shows the user in *place* of the command line if more than one user has executed a dnf command, and there is no obvious way (e.g. documented in the man page) to show the commands instead.

Steps to Reproduce:
1. Run two erase/install/update etc. commands, each as a different user.
2. sudo dnf history

Actual results:

"Command line" column is replaced by much less useful "Login user"

Expected results:

"Command line" column is always shown by default, or there is a man-documented (i.e. not --setopt) way to force its display.

Additional info:

dnf/yum history is/was a useful way of finding and undoing specific transactions, expecially uninstalling specific software and dependencies. Without the "Command line" column this is not possible.

With yum this did not happen. The issue manifested when using F22 after running "dnf migrate".

I discovered the workaround of "--setopt=history_list_view=cmds" by accident from bug 1208000 and a bit of further investigation.

An interim workaround would be to add information about the above workaround to the dnf man page. Alternatively the history_list_view option could be set to cmds by default in /etc/dnf/dnf.conf instead of 1user-cmds.

Comment 1 Honza Silhan 2015-05-29 08:36:08 UTC
Thank for the report. I also see more benefits showing the command rather than the user in history list so it could be set by default to cmd and make `history_list_view` option documented.

Comment 2 Honza Silhan 2015-07-07 15:12:38 UTC
*** Bug 1239274 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2015-08-10 10:05:11 UTC
dnf-plugins-core-0.1.10-1.fc23,dnf-1.1.0-1.fc23,hawkey-0.6.0-1.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.10-1.fc23,dnf-1.1.0-1.fc23,hawkey-0.6.0-1.fc23

Comment 4 Fedora Update System 2015-08-10 10:49:21 UTC
dnf-plugins-core-0.1.10-1.fc22,dnf-1.1.0-1.fc22,hawkey-0.6.0-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.10-1.fc22,dnf-1.1.0-1.fc22,hawkey-0.6.0-1.fc22

Comment 5 Fedora Update System 2015-08-11 02:10:36 UTC
Package dnf-plugins-core-0.1.10-1.fc22, dnf-1.1.0-1.fc22, hawkey-0.6.0-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.1.10-1.fc22 dnf-1.1.0-1.fc22 hawkey-0.6.0-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-13162/dnf-plugins-core-0.1.10-1.fc22,dnf-1.1.0-1.fc22,hawkey-0.6.0-1.fc22
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2015-08-15 02:13:30 UTC
dnf-plugins-core-0.1.10-1.fc22, hawkey-0.6.0-1.fc22, dnf-1.1.0-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2015-08-19 07:51:01 UTC
dnf-plugins-core-0.1.10-1.fc23, hawkey-0.6.0-1.fc23, dnf-1.1.0-2.fc23 has been pushed to the Fedora 23 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.