Bug 12185 - Boot.img doesn't
Summary: Boot.img doesn't
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alan Cox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-13 04:46 UTC by John Fort
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-22 19:12:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Fort 2000-06-13 04:46:56 UTC
The boot.img in RH 6.0, 6.1, 6.2 wont recognise the Initio 1060 U2SCSI card
because the code bombs in kernel/drivers/scsi/i60uscsi.c in the 
Addinia100_into_adapter_table
function.  The compiler warning that your kernel and modules builder 
ignores is, warning ambigous else if, suggest using braces.
This was fixed in patch-2.3.10 of Jul 1999. the 2.7.3.2 compiler doesn't 
need
the extra braces but the 2.91.66 does.
I dont have enough space on my old IDE disk and would rather try 
installing Red Hat on my Fast SCSI disks sometime in the future.
cu  johnf


Note You need to log in before you can comment on or make changes to this bug.