Bug 1218526 - [RHEL6.7][log-collector] Missing some info from engine's collected logs
Summary: [RHEL6.7][log-collector] Missing some info from engine's collected logs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-log-collector
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Sandro Bonazzola
QA Contact: Gonza
URL:
Whiteboard:
Depends On:
Blocks: 1225117 1234855
TreeView+ depends on / blocked
 
Reported: 2015-05-05 08:02 UTC by Gonza
Modified: 2016-03-09 20:00 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
With this release, Red Hat Enterprise Virtualization correctly handles sos 3.2, which is shipped with Red Hat Enterprise Linux 6.7.
Clone Of:
: 1225117 (view as bug list)
Environment:
Last Closed: 2016-03-09 20:00:11 UTC
oVirt Team: Integration
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0392 normal SHIPPED_LIVE rhevm-log-collector bug fix and enhancement update 2016-03-10 00:19:00 UTC
oVirt gerrit 41477 master MERGED sos: adapt to engine sosreport to sos 3.2 Never

Description Gonza 2015-05-05 08:02:15 UTC
Description of problem:
Some information from the engine logs is not collected by sosreports using log-collector. This info was collected before, possible regression.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux Server release 6.7 Beta (Santiago)
ovirt-log-collector-3.6.0-0.1.master.20150410091746.git19f1be0.el6.noarch
sos-3.2-24.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. On a RHEL6.7 engine with RHEL7.1 hosts collect logs with "engine-log-collector collect"
2. Inspect the file returned by the last


Actual results:
Bellow snippet of test log indicates which files are missing from the host's archive. 
.*/java
.*/vgdisplay
.*/proc/cpuinfo
.*/proc/ioports
.*/proc/mdstat
.*/proc/partitions
.*/proc/bus
.*/proc/scsi

Also manually verified these files are missing from the collected engine's archive. 

Expected results:
All the above files (or command outputs) are collected from engine. 

Additional info:
Discovered by automated test:
http://jenkins.qa.lab.tlv.redhat.com:8080/job/3.6-GE/25/testReport/
Ignoring:
.*/ifconfig -> replaced by .*/ip_addr
.*/sos_reports/sosreport.html -> replaced by .*/sos_reports/sos.html

Comment 7 errata-xmlrpc 2016-03-09 20:00:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0392.html


Note You need to log in before you can comment on or make changes to this bug.