Bug 1218565 - `gluster volume heal <vol-name> split-brain' shows wrong usage
Summary: `gluster volume heal <vol-name> split-brain' shows wrong usage
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Anuradha
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: qe_tracker_everglades 1223747
TreeView+ depends on / blocked
 
Reported: 2015-05-05 09:23 UTC by Shruti Sampat
Modified: 2016-09-20 02:00 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.7.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1223747 (view as bug list)
Environment:
Last Closed: 2015-11-16 09:13:48 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Shruti Sampat 2015-05-05 09:23:55 UTC
Description of problem:
------------------------

Running the following command shows wrong usage message -

# gluster v heal <vol-name> split-brain
Usage: /usr/sbin/glfsheal <VOLNAME> [bigger-file <FILE> | source-brick <HOSTNAME:BRICKNAME> [<FILE>] | split-brain-info]
Volume heal failed.

The usage above gives the name of the binary instead of the name and format of the command being run. Another thing to remove from the message is the `split-brain-info' option as that does not run with the command. See below -

# gluster v heal <vol-name> split-brain split-brain-info
Usage: volume heal <VOLNAME> [enable | disable | full |statistics [heal-count [replica <HOSTNAME:BRICKNAME>]] |info [healed | heal-failed | split-brain] |split-brain {bigger-file <FILE> |source-brick <HOSTNAME:BRICKNAME> [<FILE>]}]

Version-Release number of selected component (if applicable):
---------------------------------------------------------------

glusterfs-3.7.0alpha0-0.17.gited96153.el6.x86_64

How reproducible:
------------------

Always

Steps to Reproduce:
--------------------

1. Run the following command and observe the usage message displayed -

# gluster v heal <vol-name> split-brain
Usage: /usr/sbin/glfsheal <VOLNAME> [bigger-file <FILE> | source-brick <HOSTNAME:BRICKNAME> [<FILE>] | split-brain-info]
Volume heal failed.

Actual results:
-----------------

Usage displayed is incorrect because of the reasons explained above.

Expected results:
------------------

Usage should be correctly displayed.

Additional info:

Comment 1 Ravishankar N 2015-05-05 13:59:07 UTC
Assigning it to Anuradha as she knows the fix.

Comment 2 Anuradha 2015-06-02 10:23:45 UTC
Patch for BZ 1218570 (http://review.gluster.org/11043 ) should fix this issue too. Moving bug state to post.

Comment 3 Anuradha 2015-06-04 08:31:53 UTC
Patch has been merged on 3.7 branch. Moving the bug state to modified.


Note You need to log in before you can comment on or make changes to this bug.