Bug 1218585 - [Snapshot] Snapshot scheduler show status disable even when it is enabled
Summary: [Snapshot] Snapshot scheduler show status disable even when it is enabled
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: 3.7.0
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Avra Sengupta
QA Contact:
URL:
Whiteboard: Scheduler
Depends On: 1216931 1224234
Blocks: qe_tracker_everglades
TreeView+ depends on / blocked
 
Reported: 2015-05-05 10:06 UTC by rjoseph
Modified: 2015-05-22 11:13 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1216931
Environment:
Last Closed: 2015-05-14 17:29:36 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description rjoseph 2015-05-05 10:06:27 UTC
+++ This bug was initially created as a clone of Bug #1216931 +++

Description of problem:

Once you enable snapshot scheduler on RHEL 7.1 , and check scheduler status is show status display.

Version-Release number of selected component (if applicable):

[root@localhost ~]# rpm -qa | grep glusterfs
glusterfs-debuginfo-3.7.0alpha0-0.9.git989bea3.el7.centos.x86_64
glusterfs-cli-3.7.0alpha0-0.17.gited96153.el7.centos.x86_64
glusterfs-api-3.7.0alpha0-0.17.gited96153.el7.centos.x86_64
glusterfs-server-3.7.0alpha0-0.17.gited96153.el7.centos.x86_64
glusterfs-devel-3.7.0alpha0-0.17.gited96153.el7.centos.x86_64
glusterfs-libs-3.7.0alpha0-0.17.gited96153.el7.centos.x86_64
glusterfs-fuse-3.7.0alpha0-0.17.gited96153.el7.centos.x86_64
glusterfs-3.7.0alpha0-0.17.gited96153.el7.centos.x86_64
glusterfs-extra-xlators-3.7.0alpha0-0.17.gited96153.el7.centos.x86_64
glusterfs-geo-replication-3.7.0alpha0-0.17.gited96153.el7.centos.x86_64


How reproducible:

100%

Steps to Reproduce:
1. Initialize snapshot scheduler on each storage Node. snap_scheduler.py init
2. Enable scheduler on each storage Node. e.g snap_scheduler.py enable
3. Check the scheduler status on any once of the storage Node.  e.g snap_scheduler.py status

Actual results:


[root@localhost ~]# snap_scheduler.py status
snap_scheduler: Snapshot scheduling status: Disabled


Expected results:

Scheduler status should be enable 

Additional info:

[root@localhost ~]# gluster v info testvol
 
Volume Name: testvol
Type: Distributed-Replicate
Volume ID: 387abce2-3792-4a3b-bb02-ad7c35c40b1a
Status: Started
Number of Bricks: 2 x 2 = 4
Transport-type: tcp
Bricks:
Brick1: 10.70.47.143:/rhs/brick1/b1
Brick2: 10.70.47.145:/rhs/brick1/b2
Brick3: 10.70.47.143:/rhs/brick2/b3
Brick4: 10.70.47.145:/rhs/brick2/b4
Options Reconfigured:
features.uss: enable
features.quota-deem-statfs: on
features.quota: on
features.barrier: disable

--- Additional comment from Anand Avati on 2015-04-30 04:46:42 EDT ---

REVIEW: http://review.gluster.org/10464 (snapshot/scheduler: Use os.path.realpath() for path validation) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)

--- Additional comment from Anand Avati on 2015-05-04 08:32:56 EDT ---

REVIEW: http://review.gluster.org/10464 (snapshot/scheduler: Use os.path.realpath() for path validation) posted (#2) for review on master by Avra Sengupta (asengupt@redhat.com)

--- Additional comment from Anand Avati on 2015-05-05 00:58:28 EDT ---

REVIEW: http://review.gluster.org/10464 (snapshot/scheduler: Use os.path.realpath() for path validation) posted (#3) for review on master by Avra Sengupta (asengupt@redhat.com)

--- Additional comment from Anand Avati on 2015-05-05 05:44:58 EDT ---

COMMIT: http://review.gluster.org/10464 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 466289f75522c7e6662ccfd17cbe2f000667f77e
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Thu Apr 30 14:14:14 2015 +0530

    snapshot/scheduler: Use os.path.realpath() for path validation
    
    In order to accomodate systems, where /var/run is a symlink to
    /run, we are using os.path.realpath() for path validations.
    
    Change-Id: I4eae536867ec6c88f92c762b92f5c1966b622bde
    BUG: 1216931
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/10464
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Krishnan Parthasarathi <kparthas@redhat.com>

Comment 1 Anand Avati 2015-05-06 09:17:05 UTC
COMMIT: http://review.gluster.org/10573 committed in release-3.7 by Vijay Bellur (vbellur@redhat.com) 
------
commit 1f7c26edbbb9fa7cfc41ba2f71f6214495c5e4de
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Thu Apr 30 14:14:14 2015 +0530

    snapshot/scheduler: Use os.path.realpath() for path validation
    
    In order to accomodate systems, where /var/run is a symlink to
    /run, we are using os.path.realpath() for path validations.
    
    Change-Id: I4eae536867ec6c88f92c762b92f5c1966b622bde
    BUG: 1218585
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/10464
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Reviewed-on: http://review.gluster.org/10573

Comment 2 Niels de Vos 2015-05-14 17:29:36 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 3 Niels de Vos 2015-05-14 17:35:59 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 4 Niels de Vos 2015-05-14 17:38:21 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 5 Niels de Vos 2015-05-14 17:47:13 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.