Bug 1218700 - Plasma 5 menu icon is KDE logo, should be Fedora logo
Summary: Plasma 5 menu icon is KDE logo, should be Fedora logo
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: plasma-desktop
Version: 22
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: ---
Assignee: KDE SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException RejectedBlocker
Depends On:
Blocks: F22FinalFreezeException plasma5
TreeView+ depends on / blocked
 
Reported: 2015-05-05 15:36 UTC by Kevin Kofler
Modified: 2016-05-24 19:10 UTC (History)
15 users (show)

Fixed In Version: f22-kde-theme-22.3-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-04 20:20:14 UTC


Attachments (Terms of Use)

Description Kevin Kofler 2015-05-05 15:36:08 UTC
Description of problem:
The menu button in Plasma 5 uses the KDE logo as its icon. It should be using the Fedora logo.

Comment 1 Fedora Blocker Bugs Application 2015-05-12 16:21:15 UTC
Proposed as a Blocker for 22-final by Fedora user dmossor using the blocker tracking app because:

 Proposed as a Blocker this directly violates Final Release Criteria: Artwork

"The proposed final Fedora artwork must be included and used as the background on release-blocking desktops. All Fedora artwork visible in critical path actions on release-blocking desktops must be consistent with the proposed final theme."

Comment 2 Adam Williamson 2015-05-12 19:46:40 UTC
-1 for the same reason as cited in #1220497. This does not violate the criterion.

Comment 3 Stephen Gallagher 2015-05-13 12:31:50 UTC
-1 Blocker, but I'd also be okay with +1 Freeze Exception if the KDE SIG wants to make this change. (Particularly since F21 had the Fedora logo on its menu icon).

Comment 4 Jaroslav Reznik 2015-05-13 13:04:00 UTC
-1 blocker. I'm not sure we can use currently approved logos - the greyscale variant is probably too dark (https://fedoraproject.org/wiki/File:Fedora_infinity_grayscale.png) but will definitely fit better than color variant. So +1 FE but I'm not sure we really want logo there, maybe some hamburger menu like icon?

Comment 5 Fedora Update System 2015-05-13 14:13:57 UTC
kde-settings-22-7.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/kde-settings-22-7.fc22

Comment 6 Kamil Páral 2015-05-14 16:39:53 UTC
Discussed at the 2015-05-14 blocker review meeting.[1] Voted as RejectedBlocker AcceptedFreezeException - we don't actually require a Fedora kicker theme, but it sure would look nicer to include one if we have it, and can't be fixed for lives post-release

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2015-05-14

Comment 7 Fedora Update System 2015-05-14 22:20:41 UTC
Package kde-settings-22-7.fc22, f22-kde-theme-22.0-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kde-settings-22-7.fc22 f22-kde-theme-22.0-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-8202/f22-kde-theme-22.0-1.fc22,kde-settings-22-7.fc22
then log in and leave karma (feedback).

Comment 8 satellitgo 2015-05-16 14:04:11 UTC
(f) now replaced Ok in menu starter icon after update of plasma today

Comment 9 sultanqasim 2015-05-18 19:52:27 UTC
The fedora logo appears correctly with initial theme, but it goes away and won't come back when you switch to a different theme and then try going back to the fedora theme. Instead of the fedora or KDE logos, you get yet another logo showing up.

Steps to reproduce:
In System Settings -> Workspace Theme -> Look and Feel section, switch from the "Fedora Twenty Two" theme to the  "Breeze" theme, then press apply. You will get the incorrect k-menu logo. Switch back to the fedora theme, and the incorrect logo will persist.

I think that is all I needed to do to cause this to happen, though I may have fiddled with the desktop theme too at some point.

Screenshot showing incorrect logo with breeze dark theme:
http://i.imgur.com/hFDQhLU.png

It remains incorrect when I restore the fedora "look and feel" and theme, even after logging out and back in:
http://i.imgur.com/Q83vZWV.png

Comment 10 sultanqasim 2015-05-18 21:23:00 UTC
The incorrect icon can be very easily be changed back to the fedora logo or the KDE logo by right clicking the k-menu, selecting Application Launcher Settings, and picking an icon of choice.

As such, I don't consider the remaining behaviour a blocker as much as a minor annoyance that can be easily rectified by the user. Still, a fix for the icon changing to an unwanted one after theme changing may be nice after GA.

Comment 11 Rex Dieter 2015-05-18 21:28:53 UTC
FYI, we're only setting the initial icon, if a user customizes it, that initial setting will indeed get lost.

Comment 12 Fedora Update System 2015-05-19 00:00:37 UTC
kde-settings-22-7.fc22, f22-kde-theme-22.0-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Jan Grulich 2015-05-21 13:28:16 UTC
Reopening, because the update above didn't fix the issue properly.

Comment 14 Fedora Update System 2015-05-21 13:28:47 UTC
f22-kde-theme-22.3-1.fc22, plasma-workspace-5.3.0-8.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/FEDORA-2015-8453/plasma-workspace-5.3.0-8.fc22,f22-kde-theme-22.3-1.fc22

Comment 15 Fedora Update System 2015-05-22 02:32:20 UTC
Package f22-kde-theme-22.3-1.fc22, plasma-desktop-5.3.0-6.fc22, plasma-workspace-5.3.0-8.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing f22-kde-theme-22.3-1.fc22 plasma-desktop-5.3.0-6.fc22 plasma-workspace-5.3.0-8.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-8453/plasma-desktop-5.3.0-6.fc22,plasma-workspace-5.3.0-8.fc22,f22-kde-theme-22.3-1.fc22
then log in and leave karma (feedback).

Comment 16 Fedora Update System 2015-06-04 20:20:14 UTC
f22-kde-theme-22.3-1.fc22, plasma-desktop-5.3.0-6.fc22, plasma-workspace-5.3.0-8.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Adam Williamson 2016-05-24 18:57:27 UTC
This still seems to be broken on upgrades to current F24:

https://openqa.fedoraproject.org/tests/19021
https://openqa.fedoraproject.org/tests/19017

Installed: kde-settings-23-11.fc23.1.noarch
Upgraded: kde-settings-24-6.fc24.noarch

Installed: f24-kde-theme-24.2-1.fc24.noarch

Comment 18 Adam Williamson 2016-05-24 18:59:53 UTC
sorry, I'm on the wrong report, I think...

Comment 19 Rex Dieter 2016-05-24 19:10:58 UTC
It's ok, you want to be testing f24-kde-theme-24.3 anyway,
https://bodhi.fedoraproject.org/updates/FEDORA-2016-e84c674cd6


Note You need to log in before you can comment on or make changes to this bug.