Bug 1218717 - Files migrated should stay on a tier for a full cycle
Summary: Files migrated should stay on a tier for a full cycle
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Joseph Elwin Fernandes
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On:
Blocks: 1229268 1230857 1260923
TreeView+ depends on / blocked
 
Reported: 2015-05-05 16:37 UTC by Dan Lambright
Modified: 2016-06-20 00:01 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1229268 1230857 (view as bug list)
Environment:
Last Closed: 2016-06-16 12:58:24 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Dan Lambright 2015-05-05 16:37:14 UTC
When a file is migrated, it should stay on the destination tier for a full "cycle", meaning it should not immediately be moved based on timing on the destination tier.

Comment 1 Dan Lambright 2015-06-03 13:06:20 UTC
This problem occurs if two nodes start at different times. Each node should run promotion/demotion at the same time.

Comment 2 Anand Avati 2015-06-06 05:17:44 UTC
REVIEW: http://review.gluster.org/11110 (tier/dht: Fixing non atomic promotion/demotion w.r.t to frequency period) posted (#1) for review on master by Joseph Fernandes (josferna@redhat.com)

Comment 3 Anand Avati 2015-06-07 04:01:34 UTC
REVIEW: http://review.gluster.org/11110 (tier/dht: Fixing non atomic promotion/demotion w.r.t to frequency period) posted (#2) for review on master by Joseph Fernandes (josferna@redhat.com)

Comment 4 Anand Avati 2015-06-08 09:54:46 UTC
REVIEW: http://review.gluster.org/11110 (tier/dht: Fixing non atomic promotion/demotion w.r.t to frequency period) posted (#3) for review on master by Joseph Fernandes (josferna@redhat.com)

Comment 5 Anand Avati 2015-06-11 10:56:00 UTC
REVIEW: http://review.gluster.org/11110 (tier/dht: Fixing non atomic promotion/demotion w.r.t to frequency period) posted (#4) for review on master by Joseph Fernandes (josferna@redhat.com)

Comment 6 Anand Avati 2015-06-11 16:46:05 UTC
COMMIT: http://review.gluster.org/11110 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 46b3fde5437b293d9c0897fe167223b8f4f37c60
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Sat Jun 6 10:28:51 2015 +0530

    tier/dht: Fixing non atomic promotion/demotion w.r.t to frequency period
    
    This fixes the ping-pong issue i.e files getting demoted immediately
    after promition, caused by off-sync promotion/demotion processes.
    The solution is do promotion/demotion refering to the system time.
    To have the fix working all the file serving nodes should have
    thier system time synchronized with each other either manually or
    using a NTP Server.
    
    NOTE: The ping-pong issue can re-appear even with this fix, if the admin
    have different promotion freq period and demotion freq period, but this
    would be under the control of the admin.
    
    Change-Id: I1b33a5881d0cac143662ddb48e5b7b653aeb1271
    BUG: 1218717
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    Reviewed-on: http://review.gluster.org/11110
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 7 Nagaprasad Sathyanarayana 2015-10-25 15:12:26 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 8 Niels de Vos 2016-06-16 12:58:24 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.