Bug 1218785 - multiple org syncs fail with large number of tasks
Summary: multiple org syncs fail with large number of tasks
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories
Version: Unspecified
Hardware: x86_64
OS: Linux
medium
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-05 21:14 UTC by Chris Roberts
Modified: 2019-08-12 16:16 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-04 17:58:54 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Chris Roberts 2015-05-05 21:14:41 UTC
Description of problem:
Customers with multiple orgs when syncs are all stated for the same time/day cause sync errors and hung tasks.

Version-Release number of selected component (if applicable):

candlepin-0.9.23.1-1.el7.noarch
candlepin-common-1.0.1-1.el7.noarch
candlepin-guice-3.0-2_redhat_1.el7.noarch
candlepin-scl-1-5.el7.noarch
candlepin-scl-quartz-2.1.5-6.el7.noarch
candlepin-scl-rhino-1.7R3-3.el7.noarch
candlepin-scl-runtime-1-5.el7.noarch
candlepin-selinux-0.9.23.1-1.el7.noarch
candlepin-tomcat-0.9.23.1-1.el7.noarch
elasticsearch-0.90.10-6.el7sat.noarch
katello-1.5.0-30.el7sat.noarch
katello-certs-tools-1.5.6-1.el7sat.noarch
katello-default-ca-1.0-1.noarch
katello-installer-0.0.67-1.el7sat.noarch
katello-server-ca-1.0-1.noarch
pulp-admin-client-2.4.4-1.el7sat.noarch
pulp-katello-0.3-4.el7sat.noarch
pulp-nodes-common-2.4.4-1.el7sat.noarch
pulp-nodes-parent-2.4.4-1.el7sat.noarch
pulp-puppet-plugins-2.4.4-1.el7sat.noarch
pulp-puppet-tools-2.4.4-1.el7sat.noarch
pulp-rpm-admin-extensions-2.4.4-1.1.el7sat.noarch
pulp-rpm-plugins-2.4.4-1.1.el7sat.noarch
pulp-selinux-2.4.4-1.el7sat.noarch
pulp-server-2.4.4-1.el7sat.noarch
python-gofer-qpid-1.3.0-1.el7sat.noarch
python-isodate-0.5.0-1.pulp.el7sat.noarch
python-kombu-3.0.15-12.pulp.el7sat.noarch
python-pulp-bindings-2.4.4-1.el7sat.noarch
python-pulp-client-lib-2.4.4-1.el7sat.noarch
python-pulp-common-2.4.4-1.el7sat.noarch
python-pulp-puppet-common-2.4.4-1.el7sat.noarch
python-pulp-rpm-common-2.4.4-1.1.el7sat.noarch
python-qpid-0.22-15.el7.noarch
python-qpid-qmf-0.22-37.el7.x86_64
qpid-cpp-client-0.22-42.el7.x86_64
qpid-cpp-server-0.22-42.el7.x86_64
qpid-cpp-server-linearstore-0.22-42.el7.x86_64
qpid-java-client-0.22-7.el7.noarch
qpid-java-common-0.22-7.el7.noarch
qpid-proton-c-0.7-2.el7.x86_64
qpid-qmf-0.22-37.el7.x86_64
qpid-tools-0.22-13.el7.noarch
ruby193-rubygem-katello-1.5.0-98.el7sat.git.5.0df53a6.noarch
rubygem-hammer_cli_katello-0.0.4-14.el7sat.noarch
rubygem-smart_proxy_pulp-1.0.1-1.1.el7sat.noarch
satellite1.released-el7.satellite.lab.eng.rdu2.redhat.com-qpid-broker-1.0-1.noarch
satellite1.released-el7.satellite.lab.eng.rdu2.redhat.com-qpid-client-cert-1.0-1.noarch

How reproducible:


Steps to Reproduce:
1. create 40-50 orgs
2. sync about 5-10 repos
3. create sync plans for them all to sync at the same time

Actual results:
~13000 tasks in the queue, pending on error state, generated today.

Expected results:
all syncs to work correctly

Additional info:

Comment 1 RHEL Program Management 2015-05-05 21:33:28 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 8 Mike McCune 2016-09-01 15:39:25 UTC
This is still occurring with Satellite 6.2

Comment 14 Bryan Kearney 2018-09-04 17:58:54 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.