Bug 121879 - AOC Spectrium 5Vlr Monitor not reports several EDID tags to XFree86/VideoCard
AOC Spectrium 5Vlr Monitor not reports several EDID tags to XFree86/VideoCard
Status: CLOSED DUPLICATE of bug 73733
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2004-04-28 16:45 EDT by Maarten van Leunen
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:02:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
My New XF86Config file that works. (3.26 KB, text/plain)
2004-04-28 16:47 EDT, Maarten van Leunen
no flags Details
My Old XF86Config that "used" to work. (3.08 KB, text/plain)
2004-04-28 16:50 EDT, Maarten van Leunen
no flags Details

  None (edit)
Description Maarten van Leunen 2004-04-28 16:45:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)

Description of problem:
When entering my Monitor type (AOC Spectrum 5Vlr) into the XFree86,
XFree86 attempts to retrieve the modelines that the monitor is capable
of using EDID.

The monitor reports EDID of resolution 1024x768 and lower, while the
monitor is capable of several resolutions higher than this (examples
are 1400x1050 and 1280x1024.)

It never used to be a problem to run 1280x1024 until a few days ago,
after running a rather lengthy YUM Update session. Was the EDID
support  in XFree86 recently added to the Fedora Core 1?

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install a AOC Spectrum 5Vlr monitor
2. Install a NVidia VideoCard (I am using a Geforce 2 MX 440)
3. Run XSestup
4. Try out X.

Actual Results:  Received a resolution of 1024x768. 1280x1024 was
kicked out of the selection, because the monitor reported it
unavailable using EDID messages.

Expected Results:  I expected to get the same resolution as normal,

Additional info:

The following workaround exists for NVidia cards by changing your
Add your specific modes to the secion "Screen", SubSection "Display".
        Modes     "1400x1050" "1280x1024" "1280x960" "1024x768"
"800x600" "640xetc...
When attempting to rerun X, you will likely receive an error message
in your log file (/var/log/XFree86.0.log) saying something like:

(WW) NVIDIA(0): Not using mode "1280x1024" (height 1280 is larger than
(WW) NVIDIA(0): EDID-specified maximum 1024) 

that these modes are not supported compared to EDID messages received
from your monitor and they are effectively unavailable.

Than add the following to Section "Device" where your NVidia card is
        Option      "IgnoreEDID" "true"
        Option      "UseEdidFreqs" "false"

This will make the videocard/XFree86 ignore the messages received from
your monitor.

Most likely you will have to finetune the modelines using the
"xvidtune" program and add modeline information to Section "Monitor".
For example:

ModeLine "1400x1050"   122.00   1400 1480 1632 1888   1050 1056 1068
1090 +hsync +vsync

I am surprised that the monitor is reporting resolutions lower than it
is capable off. Is this common in monitors nowadays?
Comment 1 Maarten van Leunen 2004-04-28 16:47:01 EDT
Created attachment 99755 [details]
My New XF86Config file that works.
Comment 2 Maarten van Leunen 2004-04-28 16:50:08 EDT
Created attachment 99756 [details]
My Old XF86Config that "used" to work.
Comment 3 Mike A. Harris 2004-05-04 11:58:00 EDT

*** This bug has been marked as a duplicate of 73733 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:02:49 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.