Bug 12188 - Unconfigured hw: X, cd-rw, ls120, aha1505, 3c509
Unconfigured hw: X, cd-rw, ls120, aha1505, 3c509
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-13 05:49 EDT by giulioo
Modified: 2007-04-18 12:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-15 15:14:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description giulioo 2000-06-13 05:49:36 EDT
====
cpu: pentiumIII 450
mem: 128M
bios: Award v4.51PG
mb: Asus P2  (rev1011.A)
chipset: i440ZX
10/21/99-i440ZX-P2-99
video: Trident 3D Blade 8M
mouse: ps2, 2 buttons
keyboard: US
monitor: Olidata MR1502 (see below)
nic: 3c509

IDE devices:
hda: IDE disk
hdb: none
hdc: LS-120 (_not_ set as boot device in BIOS)
hdd: IDE CD-RW (PHILIPS PCRW804)

SCSI devices:
scsi controller: Adaptec AHA1505
scsi tape: TANDBERG TDC 3800

My language: Italian

Olidata (www.olidata.it) is the biggest Italian "system integrator" or 
whatever you call who buys parts in Asia and sells pc's.
Don't know the original maker of the monitor, Olidata re-brands them. It's 
made in china...

====



************ GUI install:
70 sec of /sbin/loader
130 sec of BLACK screen
Then video is trembling, can select language, becomes unusable when 
selecting keyboard. Aborted.
I installed 6.1 ok with GUI on the same system.


*********** Text Install 
(not expert, I deliberately chose the normal install as a new user would 
do):

==== X
My video card was detected correctly (Trident 3DBlade generic), the server 
chosen by the installer was Xfree86 instead of SVGA.

After the 1st boot:
- startx does not work "unable to open /var/log/XFree86.0.log"
- X -configure, ok, startx, X starts, screen trembling, unusable.
- Xconfigurator (some warnings about "Warning CHIPSET specification 
missing for Card database...."), startx, "server does't exist can't 
continue". X is a link to Xfree86.
- I installed the SVGA X Server and then could start X and gnome. Still 
some problems (trembling, icons with just the text labels, "gmc" segfault).

==== CD-RW
The IDE CD-RW was detected as a simple CDROM, moreover the ide-cd is not a 
module so you need to edit lilo.conf (something I prefer not to do unless 
I have no other choice), instead of just putting the config info ("option 
ide-cd ignore hdd") in /etc/modules.conf as I'm used to do.

When I did an expert install I could specify the lilo options.
However, it would be better to have ide-cd as a module.


==== AHA1505
The aha1505 is not detected; manually edited /etc/modules.conf and then 
worked.

When I did the expert install I could specify options and have it 
recognized.


==== 3c509:
3c509 not detected, manually edited /etc/modules.cond and then worked. I 
was not asked for ip address during install, just the hostname.
I chose "workstation" install.

When I did the expert install I could specify options and have it 
recognized, and I was asked the ipaddr data.

==== LS-120:
No entry for it was added in /etc/fstab. That would help new linux users 
who use formatted ls120.

For the ones who use the ls120 as a backup media, just like a tape, and 
use cpio/tar to write to it, the message
hdd: unknown partition table 
when you use it, is annoying :-)

==== /etc/hosts
/etc/hosts is messed-up with hostname on the same line of 127.0.0.1
Comment 1 Jeremy Katz 2000-06-13 21:42:56 EDT
As to the CD-RW, all current releases of Red Hat Linux currently have IDE cdrom
support compiled in instead of modular.  It would, though, make it easier to get
CD-Rs working if it were modular.

The aha1505 and 3c509 cards are not detected or asked about by default in the
text installer as they are ISA cards.  There isn't a good way to probe for ISA
cards, and if you don't select expert mode, then the installer doesn't try to
ask about ISA hardware. 

My understanding of why the hostname is on the same line in /etc/hosts is so
that network services such as sendmail and apache don't hang on startup if the
network interface does not come up on boot
Comment 2 Michael Fulbright 2000-06-14 10:36:31 EDT
katzj answered most of these issues (thanks).

ls120: We will be added /etc/fstab support for it soon.

cd-r/w: I will bring this issue up internally and find a resolution.
Comment 3 giulioo 2000-06-17 11:32:34 EDT
>My understanding of why the hostname is on the same line in /etc/hosts is so
>that network services such as sendmail and apache don't hang on startup if the
>network interface does not come up on boot

I thought "localhost.localdomain" was used for that reason.
Is it considered normal to have a network card configured properly and not to 
have its ip address in /etc/hosts?

The install programm asked for an hostname, and I gave it a fqdn.

I made a text/expert install (workstation)

This is my /etc/sysconfig/network
NETWORKING=yes
HOSTNAME=localhost.localdomain

This is my /etc/hosts 
127.0.0.1               i5.mydomain.dom i5 localhost.localdomain localhost


I think it should be:

/etc/sysconfig/network
NETWORKING=yes
HOSTNAME=i5.mydomain.dom

/etc/hosts
127.0.0.1              localhost.localdomain localhost
my.ip.address          i5.mydomain.dom i5


Comment 4 Brock Organ 2000-06-26 18:14:49 EDT
you can also try "linux isa" at the syslinux prompt to bring up a dialog for
configuring isa devices ... also, beta2 should have better support for the
ls120; please let us know if there are any problems with it ... thanks for your
report!
Comment 5 giulioo 2000-06-27 12:24:09 EDT
I'm opening more specific bug for beta2 (for ls120 and cdrw), since I've used a 
too generic summary for this bug and some of the issues have been resolved.
Comment 6 Michael Fulbright 2000-09-15 15:14:14 EDT
User split out bug report into several simpler ones, as this one is too complex.

Note You need to log in before you can comment on or make changes to this bug.