Bug 121888 - Boot console message: Module ohci1394 not found
Boot console message: Module ohci1394 not found
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-04-28 17:27 EDT by Bob Gustafson
Modified: 2014-03-16 22:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-02 16:31:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Gustafson 2004-04-28 17:27:09 EDT
Description of problem:

 Firewire ohci1394 module not found on boot

Version-Release number of selected component (if applicable):

 NA
How reproducible:

 Boot

Steps to Reproduce:
1.boot
2.watch console display
3.
  
Actual results:

  Module ohci1394 not found

Expected results:

  Module found

Additional info:

Searching disk for ohci1394 gives the following:
The kernel version is 2.6.5-1.327smp
Looks like this module was not compiled.

(Hmm - maybe was not configured in to this kernel build?)

[root@hoho2 root]# find / -name ohci1394\* -print
/usr/src/linux-2.6.3-2.1.253.2.1/drivers/ieee1394/ohci1394.mod.o
/usr/src/linux-2.6.3-2.1.253.2.1/drivers/ieee1394/ohci1394.ko
/usr/src/linux-2.6.3-2.1.253.2.1/drivers/ieee1394/ohci1394.mod.c
/usr/src/linux-2.6.3-2.1.253.2.1/drivers/ieee1394/ohci1394.o
/usr/src/linux-2.6.3-2.1.253.2.1/include/config/ieee1394/ohci1394
/usr/src/linux-2.6.3-2.1.253.2.1/.tmp_versions/ohci1394.mod
/usr/src/linux-2.6.1-1.65/include/config/ieee1394/ohci1394
/usr/src/linux-2.6.5-1.327/drivers/ieee1394/ohci1394.h
/usr/src/linux-2.6.5-1.327/drivers/ieee1394/ohci1394.c
/usr/src/linux-2.6.5/drivers/ieee1394/ohci1394.mod.o
/usr/src/linux-2.6.5/drivers/ieee1394/ohci1394.h
/usr/src/linux-2.6.5/drivers/ieee1394/ohci1394.ko
/usr/src/linux-2.6.5/drivers/ieee1394/ohci1394.mod.c
/usr/src/linux-2.6.5/drivers/ieee1394/ohci1394.c
/usr/src/linux-2.6.5/drivers/ieee1394/ohci1394.o
/usr/src/linux-2.6.5/include/config/ieee1394/ohci1394
/usr/src/linux-2.6.5/.tmp_versions/ohci1394.mod
[root@hoho2 root]#
Comment 1 Bob Gustafson 2004-05-02 13:45:06 EDT
I loaded the kernel source from the SRPMS disks (#4) and copied the
pertinent smp config file from ./configs to .config and then grepped
it for 1394. The results are shown below.

The next step is to rebuild the kernel with 1394 selected (I do have
the hardware) and see if this causes the error to go away (It should).

---
[root@hoho2 linux-2.6.5-1.327]# date
Sun May  2 12:46:12 CDT 2004
[root@hoho2 linux-2.6.5-1.327]# pwd
/usr/src/linux-2.6.5-1.327
[root@hoho2 linux-2.6.5-1.327]# grep SMP .config
# CONFIG_X86_BIGSMP is not set
CONFIG_SMP=y
CONFIG_X86_FIND_SMP_CONFIG=y
CONFIG_X86_SMP=y
[root@hoho2 linux-2.6.5-1.327]# grep 1394 .config
# IEEE 1394 (FireWire) support
# CONFIG_IEEE1394 is not set
[root@hoho2 linux-2.6.5-1.327]#
Comment 2 Bob Gustafson 2004-05-02 16:31:13 EDT
OK, I reconfigured the kernel - adding IEEE 1394 (and Telephony) support.

The boot FAILED message does not appear, but is replaced with:

May  2 15:23:40 hoho2 kernel: ohci1394: $Rev: 1172 $ Ben Collins
<bcollins@debian.org>
May  2 15:23:40 hoho2 kernel: ohci1394: fw-host0: OHCI-1394 1.0 (PCI):
IRQ=[177]  MMIO=[d0504000-d05047ff]  Max Packet=[2048]

---- looking at the changes in the .config file: ---

[user1@hoho2 linux-2.6.5-1.327]$ grep 1394 .config
# IEEE 1394 (FireWire) support
CONFIG_IEEE1394=m
# CONFIG_IEEE1394_VERBOSEDEBUG is not set
# CONFIG_IEEE1394_OUI_DB is not set
CONFIG_IEEE1394_EXTRA_CONFIG_ROMS=y
CONFIG_IEEE1394_CONFIG_ROM_IP1394=y
# CONFIG_IEEE1394_PCILYNX is not set
CONFIG_IEEE1394_OHCI1394=m
CONFIG_IEEE1394_VIDEO1394=m
CONFIG_IEEE1394_SBP2=m
# CONFIG_IEEE1394_SBP2_PHYS_DMA is not set
CONFIG_IEEE1394_ETH1394=m
CONFIG_IEEE1394_DV1394=m
CONFIG_IEEE1394_RAWIO=m
CONFIG_IEEE1394_CMP=m
CONFIG_IEEE1394_AMDTP=m
[user1@hoho2 linux-2.6.5-1.327]$ date
Sun May  2 15:26:16 CDT 2004
[user1@hoho2 linux-2.6.5-1.327]$

------ Seems to be OK now -----

[root@hoho2 log]# date
Sun May  2 15:35:15 CDT 2004
[root@hoho2 log]# cat /proc/version
Linux version 2.6.5-1.327custom (root@hoho2.chidig.com) (gcc version
3.3.3 20040412 (Red Hat Linux 3.3.3-7)) #1 SMP Sun May 2 14:08:50 CDT 2004
[root@hoho2 log]#

Comment 3 Bob Gustafson 2004-05-02 16:33:25 EDT
OK, I reconfigured the kernel - adding IEEE 1394 (and Telephony) support.

The boot FAILED message does not appear, but is replaced with:

May  2 15:23:40 hoho2 kernel: ohci1394: $Rev: 1172 $ Ben Collins
<bcollins@debian.org>
May  2 15:23:40 hoho2 kernel: ohci1394: fw-host0: OHCI-1394 1.0 (PCI):
IRQ=[177]  MMIO=[d0504000-d05047ff]  Max Packet=[2048]

---- looking at the changes in the .config file: ---

[user1@hoho2 linux-2.6.5-1.327]$ grep 1394 .config
# IEEE 1394 (FireWire) support
CONFIG_IEEE1394=m
# CONFIG_IEEE1394_VERBOSEDEBUG is not set
# CONFIG_IEEE1394_OUI_DB is not set
CONFIG_IEEE1394_EXTRA_CONFIG_ROMS=y
CONFIG_IEEE1394_CONFIG_ROM_IP1394=y
# CONFIG_IEEE1394_PCILYNX is not set
CONFIG_IEEE1394_OHCI1394=m
CONFIG_IEEE1394_VIDEO1394=m
CONFIG_IEEE1394_SBP2=m
# CONFIG_IEEE1394_SBP2_PHYS_DMA is not set
CONFIG_IEEE1394_ETH1394=m
CONFIG_IEEE1394_DV1394=m
CONFIG_IEEE1394_RAWIO=m
CONFIG_IEEE1394_CMP=m
CONFIG_IEEE1394_AMDTP=m
[user1@hoho2 linux-2.6.5-1.327]$ date
Sun May  2 15:26:16 CDT 2004
[user1@hoho2 linux-2.6.5-1.327]$

------ Seems to be OK now -----

[root@hoho2 log]# date
Sun May  2 15:35:15 CDT 2004
[root@hoho2 log]# cat /proc/version
Linux version 2.6.5-1.327custom (root@hoho2.chidig.com) (gcc version
3.3.3 20040412 (Red Hat Linux 3.3.3-7)) #1 SMP Sun May 2 14:08:50 CDT 2004
[root@hoho2 log]#
Comment 4 Bob Gustafson 2004-05-02 16:35:29 EDT
Hmm, got odd 'Mid Air collision' dialog box.

I selected 'save my changes' and got the duplicated comments shown
above. - curious.

Note You need to log in before you can comment on or make changes to this bug.