Bug 121893 - USB scanners do not have their permissions set by hotplug
USB scanners do not have their permissions set by hotplug
Status: CLOSED DUPLICATE of bug 121511
Product: Fedora
Classification: Fedora
Component: hotplug (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-28 17:44 EDT by W. Michael Petullo
Modified: 2014-03-16 22:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description W. Michael Petullo 2004-04-28 17:44:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.6)
Gecko/20040312 Epiphany/1.1.12

Description of problem:
Hotplug correctly sets the permissions of USB devices (ie:
/proc/bus/usb/001/*) when I plug in my digital camera.  Hotplug gives
read and write permissions to the console owner.

However, the same is not true for scanners.  Since the USB scanner
kernel module was dropped some time ago in favor of libusb, scanners
should be handled like digital cameras.

This is how I got my scanner to work right:

I added the following two lines to /etc/hotplug/usb.usermap (copied
from /etc/hotplug/usb.distmap -- the map for old kernel modules):

# Umax Astra 2200
scanner              0x0003 0x1606   0x0230    0x0000       0x0000   
   0x00       0x00            0x00            0x00            0x00   
        0x00       0x00000000

Then I copied /etc/hotplug/usb/usbcam to /etc/hotplug/scanner and
modified the script to reference scanners instead of cameras (actually
a slight modification of the same script could probably be used in
both cases).

Version-Release number of selected component (if applicable):
hotplug-2004_03_11-1

How reproducible:
Always

Steps to Reproduce:
Plug in a USB scanner.  Notice that the corresponding device in
/proc/bus/usb does not have its permissions set so that the
console-owning user has access. 

Additional info:
Comment 1 W. Michael Petullo 2004-05-03 10:22:36 EDT

*** This bug has been marked as a duplicate of 121511 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:02:49 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.