Bug 1218941 - Hypervisor can't list detail info of iscsi lun on select disk page once the host has connected to iscsi storage before.
Summary: Hypervisor can't list detail info of iscsi lun on select disk page once the h...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.1
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Ryan Barry
QA Contact: cshao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-06 08:59 UTC by cshao
Modified: 2016-03-09 14:28 UTC (History)
11 users (show)

Fixed In Version: ovirt-node-3.3.0-0.4.20150906git14a6024.el7ev
Doc Type: Bug Fix
Doc Text:
Fixed an issue where iSCSI information is missing for devices when re-installing Red Hat Enterprise Virtualization Hypervisor.
Clone Of:
Environment:
Last Closed: 2016-03-09 14:28:15 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
iscsi-lun.png (73.18 KB, image/png)
2015-05-06 08:59 UTC, cshao
no flags Details
iscsi.tar.gz (5.28 MB, application/x-gzip)
2015-05-06 09:01 UTC, cshao
no flags Details
latedisks-1 (194.33 KB, image/png)
2015-05-12 16:16 UTC, Ryan Barry
no flags Details
latedisks-2 (179.12 KB, image/png)
2015-05-12 16:16 UTC, Ryan Barry
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC
oVirt gerrit 40827 master MERGED Trigger udevadm in the installer to refresh disk info Never
oVirt gerrit 41121 master MERGED Add udevadm settle to ovirt-cleanup Never

Description cshao 2015-05-06 08:59:18 UTC
Created attachment 1022517 [details]
iscsi-lun.png

Description of problem:
Hypervisor can't list detail info of iscsi lun on select disk page once the host has connected to iscsi storage before.

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.1-20150505.0.el7ev
ovirt-node-3.2.2-3.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install rhev-hypervisor7-7.1-20150505.0.el7ev on iscsi machine
2. Register to RHEVM and connect iscsi storage.
3. Reinstall rhev-hypervisor7-7.1-20150505.0.el7ev
4. Focus on select disk page.
5. Try to finish the installation process

Actual results:
1. Hypervisor can't list detail info of iscsi lun on select disk page.
2. Install failed.

Expected results:
Hypervisor can list the detail info of iscsi lun on select disk page even if the host has connected to iscsi storage before.

Additional info:
No such issue when clean install.

Comment 1 cshao 2015-05-06 09:01:21 UTC
Created attachment 1022518 [details]
iscsi.tar.gz

/var/log/*.log
/tmp/ovirt.log
sosreport

Comment 2 Fabian Deutsch 2015-05-06 15:28:45 UTC
There were some patches in 3.5 related to that area.

Comment 3 Ryan Barry 2015-05-06 15:39:49 UTC
Is the RHEV-M environment still connected to the LUNs?

I may also need access to the system if you can leave it up. We get this information directly from udev, and I don't have a local hardware iscsi environment to test with.

I see an error further down the logs indicating that there's still an LV present and it should be cleaned manually. Is this the failure to install you mean? That may also still be the data domain on the LUNs, but I'd have to be on a running system to see...

Comment 4 Ying Cui 2015-05-07 03:27:02 UTC
Chen, Could you help to answer Ryan's comment 3? Thanks.

Comment 15 Ryan Barry 2015-05-12 16:16:06 UTC
Created attachment 1024679 [details]
latedisks-1

Comment 16 Ryan Barry 2015-05-12 16:16:35 UTC
Created attachment 1024680 [details]
latedisks-2

Comment 20 Fabian Deutsch 2015-05-19 09:00:43 UTC
Instead of a sleep, we can use udevadm settle to wait for teh current udev run to complete.

Comment 21 Ryan Barry 2015-05-19 14:31:01 UTC
(In reply to Fabian Deutsch from comment #20)
> Instead of a sleep, we can use udevadm settle to wait for teh current udev
> run to complete.

I'm somewhat worried that settling won't help, since the device didn't even register until after pre-pivot, but it's certainly worth trying

Comment 22 Fabian Deutsch 2015-05-29 13:12:31 UTC
In some flows the details on the TUI page are not complete, i.e the vendor is missing. As this has no functional impact I'm moving this out to 3.6.

Comment 24 cshao 2015-11-23 07:36:51 UTC
Test version:
rhev-hypervisor7-7.2-20151112.1
ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch

Test steps:
1. Install rhev-hypervisor7.2 on iscsi machine
2. Register to RHEVM and connect iscsi storage.
3. Reinstall rhev-hypervisor7.2
4. Focus on select disk page.
5. Try to finish the installation process


Test result:
Hypervisor can list the detail info of iscsi lun on select disk page even if the host has connected to iscsi storage before.

So the bug is fixed, change bug status to VERIFIED.

Comment 26 errata-xmlrpc 2016-03-09 14:28:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.