This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 121903 - After doing mount -t smbfs, accessing mount point results in "Invalid slot"
Summary: After doing mount -t smbfs, accessing mount point results in "Invalid slot"
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jay Fenlason
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Blocker
TreeView+ depends on / blocked
 
Reported: 2004-04-28 23:59 UTC by todd runstein
Modified: 2014-08-31 23:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-06 06:50:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description todd runstein 2004-04-28 23:59:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007

Description of problem:
Trying to mount with "-t smbfs" appears to work with no errors. 
However, trying to access the mount point results in:
ls: /mnt/test: Invalid slot

The smbmount.log file says the daemon is started and lists a pid.  The
smb service is running.

Have not had this problem in FC2 test1 or test2.  This was a new
install, not an upgrade and used Workstation build, choosing Samba as
additional packages


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.mount -t smbfs -o username=me //server/share /mnt/test
2.ls /mnt/test
3.
    

Expected Results:  List of files

Additional info:

Comment 1 Bas van Schaik 2004-04-29 07:33:42 UTC
I've got this problem too, but solved it by using the samba-packages
(samba-client, samba-common and samba) from Fedora Core 1 (use one of
the official mirrors, like
http://mirrors.kernel.org/fedora/core/1/i386/os/Fedora/RPMS/ to
download and then force downgrade using 'rpm -Uv --force samba*.rpm'
in the directory where you saved your packages)

This error occurred on my Fedora Core 1 test 2 system also. I think it
has something to do with cifs, because cifs wouldn't work either. When
using cifs (instead of smbfs) I got an error -13, which isn't defined
at all! And sometimes, a kernel null-pointer exception was logged in
/var/log/messages)... So... Weird bussiness ;)

Comment 2 todd runstein 2004-04-29 22:45:27 UTC
I reverted to the RPM from Core 1 and now the problem is worse.  It
still looks like mount is working, but now when I try to list the
mount point, it just hangs.  I can't even shutdown (hitting the reset
button just reminds me too much of windows 98 - yuck - I feel so dirty).

Here's some of the output in messages (I think I've got all the
relevant stuff here - hope it means something to someone):

Apr 29 15:40:04 duhiky kernel: smb_lookup: find //.Trash-todd failed,
error=-5
Apr 29 15:40:04 duhiky kernel: Unable to handle kernel NULL pointer
dereference
at virtual address 00000000
Apr 29 15:40:04 duhiky kernel:  printing eip:
Apr 29 15:40:04 duhiky kernel: 00000000
Apr 29 15:40:04 duhiky kernel: *pde = 00000000
Apr 29 15:40:04 duhiky kernel: Oops: 0000 [#1]
Apr 29 15:40:04 duhiky kernel: CPU:    0
Apr 29 15:40:04 duhiky kernel: EIP:    0060:[<00000000>]    Not tainted
Apr 29 15:40:04 duhiky kernel: EFLAGS: 00010202   (2.6.5-1.327)
Apr 29 15:40:04 duhiky kernel: EIP is at 0x0
Apr 29 15:40:04 duhiky kernel: eax: 047d1780   ebx: 0599a100   ecx:
02170b5e   edx: 087d9fa0
Apr 29 15:40:04 duhiky kernel: esi: 059d1024   edi: 04a14780   ebp:
03073a20   esp: 087d9f14
Apr 29 15:40:04 duhiky kernel: ds: 007b   es: 007b   ss: 0068
Apr 29 15:40:04 duhiky mount.smbfs[1650]: [2004/04/29 15:40:04, 0]
client/smbmount.c:send_fs_socket(405)
Apr 29 15:40:04 duhiky kernel: Process nautilus (pid: 1612,
threadinfo=087d9000
task=0895b2e0)
Apr 29 15:40:04 duhiky mount.smbfs[1650]:   mount.smbfs: entering
daemon mode for service \\hefew\c$, pid=1650
Apr 29 15:40:04 duhiky kernel: Stack: 1295000d 087d9f38 00000000
059d1000 0a11bc00 0465ac98 02170b5e 087d9fa0
Apr 29 15:40:04 duhiky kernel:        047d1780 00000000 fffe546d
047d1780 00000000 00000000 059d1000 00000002
Apr 29 15:40:04 duhiky kernel:        00000000 00000000 00000001
00000004 00000246 12959820 0465ad18 047d1780
Apr 29 15:40:04 duhiky kernel: Call Trace:
Apr 29 15:40:04 duhiky kernel:  [<1295000d>] smb_readdir+0x4d5/0x5f0
[smbfs]
Apr 29 15:40:04 duhiky kernel:  [<02170b5e>] filldir64+0x0/0x12e
Apr 29 15:40:04 duhiky kernel:  [<02170848>] vfs_readdir+0x80/0xa4
Apr 29 15:40:04 duhiky kernel:  [<02170b5e>] filldir64+0x0/0x12e
Apr 29 15:40:04 duhiky kernel:  [<02170cf1>] sys_getdents64+0x65/0xaa
Apr 29 15:40:04 duhiky kernel:  [<0216fed9>]
generic_file_fcntl+0x19e/0x207
Apr 29 15:40:04 duhiky kernel:
Apr 29 15:40:04 duhiky kernel: Code:  Bad EIP value.

Comment 3 todd runstein 2004-04-29 22:53:21 UTC
Sorry if I wasn't clear before:  I can't shutdown because the "device
is busy".  Maybe that's obvious, but I should have added it for
completeness.

Comment 4 Stefan Stefanov 2004-05-03 13:32:50 UTC
Same things here.

This looks like:
https://bugzilla.samba.org/show_bug.cgi?id=1276

Hope Fedora folks will fix this for core 2 final.

Comment 5 todd runstein 2004-05-03 16:21:41 UTC
3.0.3rc1 seems to work much better for me!  Thanks for the heads up
Stefan.

Comment 6 Stefan Stefanov 2004-05-03 17:25:03 UTC
Just an update. 3.0.3 final is out and works OK, even with FC1 RPMs.

Stefan

Comment 7 Olivier L'Heureux 2004-05-17 16:13:23 UTC
I have the same experience. The bug showed up with a vanilla
Fedora Core 2 test3, and was solved when I upgraded the 3 Samba
packages to version 3.0.3-5.


Note You need to log in before you can comment on or make changes to this bug.