Bug 121906 - IBM ThinkPad T40 network (e1000) broken after suspend (ACPI S3)
IBM ThinkPad T40 network (e1000) broken after suspend (ACPI S3)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-28 20:24 EDT by Satish Balay
Modified: 2015-01-04 17:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-08 01:11:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Satish Balay 2004-04-28 20:24:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.5)
Gecko/20031208

Description of problem:
Network just hangs after a while after suspend/resume (for eg: when
downloading stuff with lftp)

Version-Release number of selected component (if applicable):
kernel-2.6.5-1.327

How reproducible:
Always

Steps to Reproduce:
1. Install FC2T3 on an IBM ThinkPad T40
2. Start up networking (eth0 / e1000)
3. suspend using: echo 3 > /proc/acpi/sleep
4. recover from suspend by pressing 'power' button
3. lftp mirror....
4.  mget *.rpm
    

Actual Results:  
< netowk hangs after a while>
    

Expected Results:  no such hang

Additional info:

I've posted about this in fedora-test-list a while back with rawhide
http://www.redhat.com/archives/fedora-test-list/2004-April/msg01857.html

02:01.0 Ethernet controller: Intel Corp. 82540EP Gigabit Ethernet
Controller (Mobile) (rev 03)

<When the hang happens - from /var/log/messages>
Apr 28 19:57:48 asterix kernel: Restarting tasks... done             
                                                                Apr 28
19:57:48 asterix kernel: agpgart: Found an AGP 2.0 compliant device at
0000:00:00.0.
Apr 28 18:46:14 asterix input.agent[2255]: ... no modules for INPUT
product                                                           Apr
28 18:46:14 asterix input.agent[2264]: ... no modules for INPUT product
Apr 28 19:57:48 asterix kernel: agpgart: Putting AGP V2 device at
0000:00:00.0 into 1x mode                                          
Apr 28 18:46:14 asterix input.agent[2273]: ... no modules for INPUT
product 11/2/1/0
Apr 28 18:46:14 asterix kernel: agpgart: Putting AGP V2 device at
0000:01:00.0 into 1x mode                                          
Apr 28 18:46:14 asterix kernel: [drm] Loading R200 Microcode
Apr 28 18:46:14 asterix kernel: input: PS/2 Generic Mouse on
isa0060/serio1                                                       
   Apr 28 18:46:15 asterix kernel: e1000: eth0 NIC Link is Up 100 Mbps
Full Duplex
Apr 28 18:47:00 asterix kernel: NETDEV WATCHDOG: eth0: transmit timed
out                                                             Apr 28
18:47:02 asterix kernel: e1000: eth0 NIC Link is Up 100 Mbps Full Duplex
Apr 28 18:47:37 asterix kernel: NETDEV WATCHDOG: eth0: transmit timed out


-----------------

BTW: When recovering from suspend - I see some 'wierd chars' printed
on the <suspend-console-screen>. Don't know how to get to this screen
- as it just pops-up briefly during susend - and resume
Comment 1 Satish Balay 2004-04-30 11:23:25 EDT
The driver appears to work fine with APM (acpi=off). The same behavior
happens with kernel-2.6.5-1.344
Comment 2 Didier 2004-05-05 16:39:12 EDT
Identical behaviour with kernel 2.6.5-1.349, IBM ThinkPad A30p, e100 ;
rmmod'ing and modprobing e100 and mii does not resolve the issue :

eth0 NIC link detects 100 Mbps Full Duplex, but subsequent dhclient
eth0 fails to communicate with DHCP server.

Does this qualify for a bug #121020 blocker ?
Comment 3 Rick Floyd 2004-06-12 02:50:09 EDT
Still present with kernel 2.6.6-1.427, on a Thinkpad T41 (2373 4HU). I
had to rmmod ehci_hcd to get ACPI suspend to work on this kernel, but
except for that and reloading it the sequence is the same as above.
eth0 restarts OK:

Jun 12 02:09:19 localhost kernel: e1000: eth0: e1000_watchdog: NIC
Link is Up 100 Mbps Half Duplex

but transfers hang after a few MB. Problem not seen until an ACPI
suspend/resume has been performed.

FWIW, I see earlier in the log that there are some issues with the
parms for this driver:

Jun 12 01:57:48 localhost kernel: e1000: Ignoring new-style parameters
in presence of obsolete ones
Jun 12 01:57:48 localhost kernel: Intel(R) PRO/1000 Network Driver -
version 5.2.52-k4
Jun 12 01:57:48 localhost kernel: Copyright (c) 1999-2004 Intel
Corporation.
Jun 12 01:57:48 localhost kernel: e1000: eth0: e1000_probe: Intel(R)
PRO/1000 Network Connection
Jun 12 01:57:48 localhost kernel: e1000: eth0: e1000_watchdog: NIC
Link is Up 100 Mbps Half Duplex

Comment 4 Satish Balay 2004-10-15 13:13:51 EDT
I tried with fc3t3/rawhide  2.6.8-1.624 kernel today - and I can't
reporduce this anymore. (downloaded 700mb of stuff after ACPI
suspend/resume)

Perhpas this issue got fixed upstream - since the last time I tried it
out.

Note You need to log in before you can comment on or make changes to this bug.