Bug 1219220 - idm-console-framework: remove versioned jars from %{_javadir}
Summary: idm-console-framework: remove versioned jars from %{_javadir}
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Directory Server
Classification: Red Hat
Component: Directory Console
Version: 10.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: DS10.0
: ---
Assignee: Rich Megginson
QA Contact: Viktor Ashirov
URL:
Whiteboard:
Depends On: 1022104
Blocks: 1022024
TreeView+ depends on / blocked
 
Reported: 2015-05-06 20:48 UTC by Viktor Ashirov
Modified: 2015-06-12 01:04 UTC (History)
6 users (show)

Fixed In Version: idm-console-framework-1.1.9-1.el7dsrv 389-console-1.1.8-1.el7dsrv
Doc Type: Bug Fix
Doc Text:
Clone Of: 1022104
Environment:
Last Closed: 2015-06-12 01:04:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1094 normal SHIPPED_LIVE Red Hat Directory Server bug fix and enhancement update 2015-06-12 05:02:14 UTC

Comment 2 Viktor Ashirov 2015-05-13 19:42:05 UTC
Builds tested:
idm-console-framework-1.1.12-1.el7dsrv.noarch.rpm
389-admin-console-1.1.10-1.el7dsrv.noarch.rpm
389-console-1.1.9-1.el7.noarch.rpm
389-ds-console-1.2.12-1.el7dsrv.noarch.rpm

idm-console-framework seems fine:
$ rpm2cpio idm-console-framework-1.1.12-1.el7dsrv.noarch.rpm | cpio -civt
drwxr-xr-x   2 root     root            0 Apr 28 19:54 ./usr/share/doc/idm-console-framework-1.1.12
-rw-r--r--   1 root     root        18425 Apr 28 19:23 ./usr/share/doc/idm-console-framework-1.1.12/LICENSE
-rw-r--r--   1 root     root        40308 Apr 28 19:54 ./usr/share/java/idm-console-base.jar
-rw-r--r--   1 root     root      1057030 Apr 28 19:54 ./usr/share/java/idm-console-mcc.jar
-rw-r--r--   1 root     root        94171 Apr 28 19:54 ./usr/share/java/idm-console-mcc_en.jar
-rw-r--r--   1 root     root        26642 Apr 28 19:54 ./usr/share/java/idm-console-nmclf.jar
-rw-r--r--   1 root     root        10333 Apr 28 19:54 ./usr/share/java/idm-console-nmclf_en.jar
2438 blocks

But other packages contain versioned jars: 
$ rpm2cpio 389-console-1.1.9-1.el7.noarch.rpm | cpio -civt
-rw-r--r--   1 root     root          323 Mar  9 21:21 ./etc/java/389-console.conf
-rwxr-xr-x   1 root     root          725 Mar  9 21:21 ./usr/bin/389-console
drwxr-xr-x   2 root     root            0 Mar  9 21:21 ./usr/share/doc/389-console-1.1.9
-rw-r--r--   1 root     root        18425 Feb  5 19:45 ./usr/share/doc/389-console-1.1.9/LICENSE
lrwxrwxrwx   1 root     root           18 Mar  9 21:21 ./usr/share/java/389-console-1.1.9_en.jar -> 389-console_en.jar
lrwxrwxrwx   1 root     root           24 Mar  9 21:21 ./usr/share/java/389-console-1.1_en.jar -> 389-console-1.1.9_en.jar
-rw-r--r--   1 root     root        61706 Mar  9 21:21 ./usr/share/java/389-console_en.jar
-rw-r--r--   1 root     root         1116 Mar  9 21:21 ./usr/share/man/man8/389-console.8.gz
164 blocks

$ rpm2cpio 389-ds-console-1.2.12-1.el7dsrv.noarch.rpm | cpio -civt
-rw-r--r--   1 root     root      1468109 Apr 15 21:14 ./usr/share/dirsrv/html/java/389-ds-1.2.12.jar
-rw-r--r--   1 root     root        71315 Apr 15 21:14 ./usr/share/dirsrv/html/java/389-ds-1.2.12_en.jar
lrwxrwxrwx   1 root     root           17 Apr 15 21:14 ./usr/share/dirsrv/html/java/389-ds-1.2.jar -> 389-ds-1.2.12.jar
lrwxrwxrwx   1 root     root           20 Apr 15 21:14 ./usr/share/dirsrv/html/java/389-ds-1.2_en.jar -> 389-ds-1.2.12_en.jar
lrwxrwxrwx   1 root     root           17 Apr 15 21:14 ./usr/share/dirsrv/html/java/389-ds.jar -> 389-ds-1.2.12.jar
lrwxrwxrwx   1 root     root           20 Apr 15 21:14 ./usr/share/dirsrv/html/java/389-ds_en.jar -> 389-ds-1.2.12_en.jar
drwxr-xr-x   2 root     root            0 Apr 15 21:14 ./usr/share/doc/389-ds-console-1.2.12
-rw-r--r--   1 root     root        12279 Apr 15 20:37 ./usr/share/doc/389-ds-console-1.2.12/LICENSE
3034 blocks

$ rpm2cpio 389-admin-console-1.1.10-1.el7dsrv.noarch.rpm | cpio -civt
-rw-r--r--   1 root     root       181030 Feb 12 00:03 ./usr/share/dirsrv/html/java/389-admin-1.1.10.jar
-rw-r--r--   1 root     root        35218 Feb 12 00:03 ./usr/share/dirsrv/html/java/389-admin-1.1.10_en.jar
lrwxrwxrwx   1 root     root           20 Feb 12 00:03 ./usr/share/dirsrv/html/java/389-admin-1.1.jar -> 389-admin-1.1.10.jar
lrwxrwxrwx   1 root     root           23 Feb 12 00:03 ./usr/share/dirsrv/html/java/389-admin-1.1_en.jar -> 389-admin-1.1.10_en.jar
lrwxrwxrwx   1 root     root           20 Feb 12 00:03 ./usr/share/dirsrv/html/java/389-admin.jar -> 389-admin-1.1.10.jar
lrwxrwxrwx   1 root     root           23 Feb 12 00:03 ./usr/share/dirsrv/html/java/389-admin_en.jar -> 389-admin-1.1.10_en.jar
drwxr-xr-x   2 root     root            0 Feb 12 00:03 ./usr/share/doc/389-admin-console-1.1.10
-rw-r--r--   1 root     root        12279 Feb 11 23:18 ./usr/share/doc/389-admin-console-1.1.10/LICENSE
450 blocks

Comment 3 Noriko Hosoi 2015-05-13 22:27:35 UTC
Hi Viktor,

May I ask you about the version of 389-console?  I cannot find 1.1.9-1.el7 on brew https://brewweb.devel.redhat.com/packageinfo?packageID=31931.  And 1.1.8 is attached to the errata https://errata.devel.redhat.com/advisory/19547/builds:
Brew 389-console-1.1.8-1.el7dsrv.noarch.rpm

It has no version'ed jar files.
rpm2cpio 389-console-1.1.8-1.el7dsrv.noarch.rpm | cpio -civt
-rw-r--r--   1 root     root          323 Dec 22 14:28 ./etc/java/389-console.conf
-rwxr-xr-x   1 root     root          725 Dec 22 14:28 ./usr/bin/389-console
drwxr-xr-x   2 root     root            0 Dec 22 14:28 ./usr/share/doc/389-console-1.1.8
-rw-r--r--   1 root     root        18425 Dec 22 14:13 ./usr/share/doc/389-console-1.1.8/LICENSE
-rw-r--r--   1 root     root        61706 Dec 22 14:28 ./usr/share/java/389-console_en.jar
-rw-r--r--   1 root     root         1116 Dec 22 14:28 ./usr/share/man/man8/389-console.8.gz
163 blocks

Regarding these 2, we have to discuss on the mailing list... :)
389-ds-console-1.2.12-1.el7dsrv.noarch.rpm
389-admin-console-1.1.10-1.el7dsrv.noarch.rpm

Comment 4 Viktor Ashirov 2015-05-13 22:42:43 UTC
Hi Noriko,
(In reply to Noriko Hosoi from comment #3)
> Hi Viktor,
> 
> May I ask you about the version of 389-console?  I cannot find 1.1.9-1.el7
> on brew https://brewweb.devel.redhat.com/packageinfo?packageID=31931.  And
> 1.1.8 is attached to the errata
> https://errata.devel.redhat.com/advisory/19547/builds:
> Brew 389-console-1.1.8-1.el7dsrv.noarch.rpm

My bad, I had epel-testing repo enabled. 1.1.9-1.el7 was coming from there: 
https://dl.fedoraproject.org/pub/epel/testing/7/x86_64/3/
http://koji.fedoraproject.org/koji/buildinfo?buildID=619186
> 
> It has no version'ed jar files.
> rpm2cpio 389-console-1.1.8-1.el7dsrv.noarch.rpm | cpio -civt
> -rw-r--r--   1 root     root          323 Dec 22 14:28
> ./etc/java/389-console.conf
> -rwxr-xr-x   1 root     root          725 Dec 22 14:28 ./usr/bin/389-console
> drwxr-xr-x   2 root     root            0 Dec 22 14:28
> ./usr/share/doc/389-console-1.1.8
> -rw-r--r--   1 root     root        18425 Dec 22 14:13
> ./usr/share/doc/389-console-1.1.8/LICENSE
> -rw-r--r--   1 root     root        61706 Dec 22 14:28
> ./usr/share/java/389-console_en.jar
> -rw-r--r--   1 root     root         1116 Dec 22 14:28
> ./usr/share/man/man8/389-console.8.gz
> 163 blocks
> 
Yes, I can confirm, that 389-console-1.1.8-1.el7dsrv has no versioned jar files. 

> Regarding these 2, we have to discuss on the mailing list... :)
> 389-ds-console-1.2.12-1.el7dsrv.noarch.rpm
> 389-admin-console-1.1.10-1.el7dsrv.noarch.rpm
Okay.

Comment 5 Rich Megginson 2015-05-13 22:48:59 UTC
The short answer is that the restriction on versioned jar files only applies to standard system locations, not our project specific directory /usr/share/dirsrv/html/java.

Comment 6 Viktor Ashirov 2015-05-13 23:04:57 UTC
Thank you, Rich!

Since idm-console-framework-1.1.9-1.el7dsrv and 389-console-1.1.8-1.el7dsrv do not contain versioned jars, marking this bug as VERIFIED.

Comment 7 Noriko Hosoi 2015-05-13 23:08:35 UTC
Thank you, Viktor!

Comment 9 errata-xmlrpc 2015-06-12 01:04:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1094


Note You need to log in before you can comment on or make changes to this bug.