Bug 1219402 - IPA suggests to uninstall a client when the user needs to uninstall a replica
Summary: IPA suggests to uninstall a client when the user needs to uninstall a replica
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Namita Soman
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-07 09:04 UTC by Aneta Šteflová Petrová
Modified: 2016-11-04 05:45 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 05:45:40 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Aneta Šteflová Petrová 2015-05-07 09:04:21 UTC
Description of problem:
When I attempt to install a replica on a system where a replica is already installed, I get a warning that an IPA client is configured and that I have to uninstall it using "ipa-client-install --uninstall". However, what I really need to do is to run "ipa-server-install --uninstall":

[root@vm-077 ~]# ipa-replica-install /var/lib/ipa/replica-info-vm-077.abc.idm.lab.eng.brq.redhat.com.gpg --setup-dns --forwarder 10.38.5.26
IPA client is already configured on this system.
Please uninstall it first before configuring the replica, using 'ipa-client-install --uninstall'.
[root@vm-077 ~]# ipa-client-install --uninstall
IPA client is configured as a part of IPA server on this system.
Refer to ipa-server-install for uninstallation.

How reproducible:
Always

Steps to Reproduce:
1. Install a replica
2. Forget that you have already done it and run ipa-replica-install again

Actual results:
IPA advises to uninstall the client using "ipa-client-install --uninstall".

Expected results:
IPA should tell the user to uninstall the replica.
(Alternatively, it could advise to run "ipa-replica-manage del" first on the initial master and then uninstall the replica.)

Comment 3 Petr Vobornik 2015-05-11 10:52:08 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5022

Comment 4 Martin Bašti 2015-12-11 17:28:07 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/12e7f71600e62eab9d48a13fba37d2f182c8bdee

Comment 5 Mike McCune 2016-03-28 22:43:24 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 7 Sudhir Menon 2016-09-16 07:45:29 UTC
Verified on RHEL73 using ipa-server-4.4.0-11.el7.x86_64

IPA doesnot advise to uninstall the client using "ipa-client-install --uninstall" instead it asks to uninstall ipa-server.

[root@ipareplica1 vagrant]# ipa-replica-install 
ipa.ipapython.install.cli.install_tool(Replica): ERROR IPA server is already configured on this system.
If you want to reinstall the IPA server, please uninstall it first using 'ipa-server-install --uninstall'.
ipa.ipapython.install.cli.install_tool(Replica): ERROR    The ipa-replica-install command failed. See /var/log/ipareplica-install.log for more information

[root@replica ~]# /usr/sbin/ipa-server-install --uninstall
This is a NON REVERSIBLE operation and will delete all data and configuration!
Are you sure you want to continue with the uninstall procedure? [no]: yes
Replication agreements with the following IPA masters found: 
master.test-relm.test. Removing any replication agreements before uninstalling the server is strongly recommended. You can remove replication agreements by running the following command on any other IPA master:
$ ipa-replica-manage del replica.test-relm.test

Comment 9 errata-xmlrpc 2016-11-04 05:45:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.