Bug 1219427 - Error launching delete dialog when try to delete guest with disk type volume
Summary: Error launching delete dialog when try to delete guest with disk type volume
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager
Version: 7.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Giuseppe Scrivano
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-07 10:24 UTC by tingting zheng
Modified: 2015-11-19 05:25 UTC (History)
4 users (show)

Fixed In Version: virt-manager-1.2.0-3-el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 05:25:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2206 0 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2015-11-19 08:17:29 UTC

Description tingting zheng 2015-05-07 10:24:17 UTC
Description
Error launching delete dialog when try to delete guest with disk type volume

Version:
libvirt-1.2.15-1.el7.x86_64
virt-manager-1.2.0-2.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1.Prepare a guest with disk type volume.
# virsh dumpxml rhel6.7-x64
    <disk type='volume' device='disk'>
      <driver name='qemu' type='raw' cache='none'/>
      <source pool='default' volume='rhel6.7-x64.img'/>
      <target dev='vda' bus='virtio'/>
      <boot order='2'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x0'/>
    </disk>

2.Launch virt-manager,right click->Delete,error shows as below:
Error launching delete dialog: 'NoneType' object has no attribute 'get_target_path'

Actual results:
As description.

Expected results:
The guest can be deleted successfully.

Additional info:
Detailed error info:
Error launching delete dialog: 'NoneType' object has no attribute 'get_target_path'

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 1129, in _do_delete_domain
    self.delete_dialog.show(vm, src.topwin)
  File "/usr/share/virt-manager/virtManager/delete.py", line 73, in show
    self.reset_state()
  File "/usr/share/virt-manager/virtManager/delete.py", line 106, in reset_state
    self.vm, self.conn)
  File "/usr/share/virt-manager/virtManager/delete.py", line 246, in populate_storage_list
    d in vm.get_disk_devices()]
  File "/usr/share/virt-manager/virtManager/delete.py", line 240, in get_path
    return vol.get_target_path()
AttributeError: 'NoneType' object has no attribute 'get_target_path'

Comment 4 Giuseppe Scrivano 2015-05-07 11:53:53 UTC
patch proposed upstream:

https://www.redhat.com/archives/virt-tools-list/2015-May/msg00019.html

Comment 7 fwu 2015-05-27 08:35:45 UTC
I can reproduce this bug with package:
virt-manager-1.2.0-2.el7.noarch

Steps are the same as description above.

Then try to verify with new build:
virt-manager-1.2.0-4.el7.noarch

Steps:
1.Prepare a guest with disk type volume.
# virsh dumpxml wf6.6-clone
<disk type='volume' device='disk'>
      <driver name='qemu' type='raw'/>
      <source pool='default' volume='wfguest6.6-clone.img'/>
      <target dev='vda' bus='virtio'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x0'/>
</disk>

2. Launch virt-manager,right click->Delete

3. On the pop-up window, click 'Delete'

4. On the pop-up window, choose 'Yes'

Results:
After step 4, the VM can be deleted successfully.

According to the result above in the latest version of virt-manager, move this bug from ON_QA to VERIFIED.

Comment 9 errata-xmlrpc 2015-11-19 05:25:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2206.html


Note You need to log in before you can comment on or make changes to this bug.