Bug 121957 - Impossible to browse a memory stick using Nautilus when recognized by updfstab
Impossible to browse a memory stick using Nautilus when recognized by updfstab
Status: CLOSED DUPLICATE of bug 129966
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-29 06:56 EDT by Julien Olivier
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julien Olivier 2004-04-29 06:56:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
I have added my memory stick description to
/etc/updfstab.conf.default, and now an entry for it is automatically
added in /etc/fstab.

The problem is that, using this method, I get the following bug:

When I try to access it using command line (after running "mount
/mnt/flash"), it works fine (I can 'ls' and 'cd' in all the folders
and sub-folders).

However, using Nautilus, this doesn't work at all.

When I double-click on a sub-folder inside /mnt/flash, Nautilus tries
to access the subfolder and gets stuck (it asks me whether I want to
cancel the operation).
If I close the "/mnt/flash" folder, Nautilus crashes...
Now that I have tried to access the memory stick using Nautilus, I
can't access it using command line either. 'ls' in a sub-folder gets
stuck forever...
I can't umount the stick either (even after killing fam). It says it's
in use, but lsof "/mnt/flash" doesn't return anything...

I also have a digital camera, which is recognized as a USB mass
storage and this one works well with Nautilus...

What's important to note is that, if I mount the memory stick myself
using "mount -t auto /dev/sda1 /mnt/flash", it works well, both in
Nautilus and command line...

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Configure /etc/updfstab.conf.default to match my memory stick
2.Insert the memory stick
3.Browse it using Nautilus
    

Actual Results:  Impossible to get to sub-folders.
Closing the memory stick's folder crashes Nautilus.
It's then impossible to unmount it.

Expected Results:  I should be able to browse it using Nautilus.

Additional info:

Here is what I have in my /etc/updfstab.conf.default, in the flash
section:

device flash {
    partition 1
    match   hd CompactFlash
    match   hd ImageMate
    match   hd Flash
    match   hd JumpDrive
    match   hd MuVo
    match   hd ClipDrive
    match   hd "Generic Traveling Disk"
    match   hd "Jungsoft NEXDISK"
    match   hd "I0mega"
}

I added the last line: "I0mega".
Comment 1 Alexander Larsson 2004-10-05 07:49:42 EDT
This looks very similary to bug 129966.
I'm marking this a duplicate.


*** This bug has been marked as a duplicate of 129966 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:02:51 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.