Bug 1219599 - Docker Plugin is not picking up Translations
Summary: Docker Plugin is not picking up Translations
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Container Management
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Daniel Lobato Garcia
QA Contact: Corey Welton
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-07 18:23 UTC by Bryan Kearney
Modified: 2019-09-25 20:50 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:15:31 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot (171.18 KB, image/png)
2015-05-07 18:29 UTC, Bryan Kearney
no flags Details
failed-screenshot (239.95 KB, image/png)
2015-07-15 01:45 UTC, Elyézer Rezende
no flags Details
container menu not changed (51.00 KB, image/png)
2015-07-31 09:44 UTC, Tazim Kolhar
no flags Details
Menus in Deutsch (59.62 KB, image/png)
2016-03-18 15:43 UTC, Og Maciel
no flags Details
Menu is French (57.79 KB, image/png)
2016-03-18 15:45 UTC, Og Maciel
no flags Details
Menus in Japanse (50.51 KB, image/png)
2016-03-18 15:50 UTC, Og Maciel
no flags Details
German Translation (63.70 KB, image/png)
2016-04-11 08:41 UTC, Tazim Kolhar
no flags Details
Japanese (49.02 KB, image/png)
2016-04-11 08:47 UTC, Tazim Kolhar
no flags Details
French translation (53.35 KB, image/png)
2016-04-11 08:47 UTC, Tazim Kolhar
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Foreman Issue Tracker 11984 None None None 2016-03-31 16:46:44 UTC
Foreman Issue Tracker 13391 None None None 2016-03-31 16:46:27 UTC
Foreman Issue Tracker 14244 None None None 2016-03-31 16:47:00 UTC

Description Bryan Kearney 2015-05-07 18:23:54 UTC
There are certain translations which are not picked up by the docker plugin. They appear to be translated, but are showing up in english when the users account preference is set to German.

Examples Inlucde:

Menu Item:
Containers 
Containers -> All containers
Containers -> New container

Error code:

You need a Docker compute resource in order to create containers. Please add a new one and try again.

Comment 1 Bryan Kearney 2015-05-07 18:29:34 UTC
Created attachment 1023235 [details]
Screenshot

Comment 2 Bryan Kearney 2015-05-07 18:30:16 UTC
Created redmine issue http://projects.theforeman.org/issues/10416 from this bug

Comment 3 RHEL Product and Program Management 2015-05-07 18:32:30 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 6 Bryan Kearney 2015-06-02 16:05:17 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/10416 has been closed
-------------
Daniel Lobato Garcia
Applied in changeset commit:foreman-docker|04db1530cc3e60d8d5fca2e58156c43ba1ade50d.

Comment 7 Daniel Lobato Garcia 2015-06-09 16:01:44 UTC
Latest code on SATELLITE-6.1.0 branch of Foreman + foreman-docker should render like this: 


http://i.imgur.com/NcrfoKX.png

Let me know if that is not the case.

Comment 8 Bryan Kearney 2015-06-15 14:39:33 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/10416 has been closed
-------------
Daniel Lobato Garcia
Applied in changeset commit:foreman-docker|04db1530cc3e60d8d5fca2e58156c43ba1ade50d.

Comment 9 Elyézer Rezende 2015-07-15 01:43:04 UTC
Failed on: Snap 12

Steps:

Changed the user preferred language.

See attached screenshot for more info

Comment 10 Elyézer Rezende 2015-07-15 01:45:29 UTC
Created attachment 1052140 [details]
failed-screenshot

Tried other languages and got the same presented on this screenshot.

Comment 13 Tazim Kolhar 2015-07-31 09:43:06 UTC
FAILEDQA:
# rpm -qa | grep foreman
foreman-1.7.2.33-1.el7sat.noarch
ruby193-rubygem-foreman-redhat_access-0.2.1-1.el7sat.noarch
foreman-vmware-1.7.2.33-1.el7sat.noarch
rubygem-hammer_cli_foreman-0.1.4.14-1.el7sat.noarch
ruby193-rubygem-foreman_gutterball-0.0.1.9-1.el7sat.noarch
foreman-postgresql-1.7.2.33-1.el7sat.noarch
foreman-debug-1.7.2.33-1.el7sat.noarch
foreman-gce-1.7.2.33-1.el7sat.noarch
ruby193-rubygem-foreman_hooks-0.3.7-2.el7sat.noarch
rubygem-hammer_cli_foreman_bootdisk-0.1.2.7-1.el7sat.noarch
rubygem-hammer_cli_foreman_docker-0.0.3.9-1.el7sat.noarch
ruby193-rubygem-foreman_docker-1.2.0.18-1.el7sat.noarch
ruby193-rubygem-foreman_discovery-2.0.0.19-1.el7sat.noarch
rubygem-hammer_cli_foreman_discovery-0.0.1.10-1.el7sat.noarch
foreman-proxy-1.7.2.5-1.el7sat.noarch
hp-z600-01.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
hp-z600-01.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
foreman-ovirt-1.7.2.33-1.el7sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3.5-1.el7sat.noarch
foreman-selinux-1.7.2.13-1.el7sat.noarch
ruby193-rubygem-foreman_bootdisk-4.0.2.13-1.el7sat.noarch
hp-z600-01.rhts.eng.bos.redhat.com-foreman-proxy-1.0-1.noarch
foreman-compute-1.7.2.33-1.el7sat.noarch
ruby193-rubygem-foreman-tasks-0.6.15.4-1.el7sat.noarch
foreman-libvirt-1.7.2.33-1.el7sat.noarch

steps:
Menu Item:
Containers 
Containers -> All containers
Containers -> New container

screen shot attached

Comment 14 Tazim Kolhar 2015-07-31 09:44:04 UTC
Created attachment 1058006 [details]
container menu not changed

Comment 15 Daniel Lobato Garcia 2016-03-11 09:12:33 UTC
Tazim - or someone else can you rereview? This was fixed a long time ago

http://imgur.com/a/qUzXr

Comment 16 Og Maciel 2016-03-18 15:43:48 UTC
Created attachment 1137814 [details]
Menus in Deutsch

Containers menu is not translated in Deutsch

Comment 17 Og Maciel 2016-03-18 15:45:00 UTC
Created attachment 1137815 [details]
Menu is French

Containers menu is not translated in French

Comment 18 Og Maciel 2016-03-18 15:50:21 UTC
Created attachment 1137816 [details]
Menus in Japanse

Containers menu is not translated in Japanese

Comment 19 Og Maciel 2016-03-18 16:01:20 UTC
As per comments #16-#18 I have tried to check the translation for the Containers menu using 3 different languages: French, German and Japanese. The following 2 methods were employed:

* Using the Language field under the "My Account" page and selecting a different language
* Creating a new Firefox profile, setting the user's language as either French, German or Japanese, re-starting the new profile and visiting the web ui

Every attempt showed that though most of the menus are somewhat translated (see attached screenshots), the Containers menu itself and its submenus were not.

This issue fails QE on Satellite 6.2.0 SNAP 4.0

Comment 20 Daniel Lobato Garcia 2016-03-29 14:06:10 UTC
I was finally able to reproduce in a production environment, on development it worked just fine. It has to deal with these 3 commits:

https://github.com/theforeman/foreman-docker/commit/cdb458e0480118c4bd3f919aaffac82e329eb320
https://github.com/theforeman/foreman-docker/commit/792d601d5c214e5bba2f26f6291f5dde24232b67
https://github.com/theforeman/foreman-docker/commit/b0e98702f29bfbab6f32c145b4bea2ab7e44bd5e

which are not released yet. I'll see if I can release again or just cp these, they do fix the issue with the docker past being 'half' translated.

Comment 21 Daniel Lobato Garcia 2016-03-30 13:37:37 UTC
Merged as:

47cd2a9b66d0486865bb2b9a52820dc94f4064ae
dd1fcb21ce4f3d5f94cb8d30b189ac71ec0eee18
2bdcc7f80b48bf2efcbd2e25d0f7c289ee0bb409

Comment 22 Tazim Kolhar 2016-04-11 08:40:49 UTC
VERIFIED:
# rpm -qa foreman
foreman-1.11.0.11-1.el7sat.noarch


Steps:
Menu Item:
Containers 
Containers -> All containers
Containers -> New container

The translation is properly done in German 
screenshot attached

Comment 23 Tazim Kolhar 2016-04-11 08:41:50 UTC
Created attachment 1145867 [details]
German Translation

Comment 24 Tazim Kolhar 2016-04-11 08:47:03 UTC
Created attachment 1145868 [details]
Japanese

Comment 25 Tazim Kolhar 2016-04-11 08:47:44 UTC
Created attachment 1145869 [details]
French translation

Comment 28 errata-xmlrpc 2016-07-27 09:15:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.