Bug 121960 - Cannot record from Creative Audigy 2 ZS Platinum Optical Input
Cannot record from Creative Audigy 2 ZS Platinum Optical Input
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-29 07:13 EDT by Paul Tourville
Modified: 2015-01-04 17:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-08 11:52:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Tourville 2004-04-29 07:13:09 EDT
Description of problem: I can play audio through the Optical Input on
my new Audigy 2 ZS Platinum, but I can't get Krec to record from that
input, and "Sound Recorder" crashes when I click the "Record" button.
 Audio signal is coming from Roland VS-840EX digital multitrack
recorder.  I can cat /dev/dsp to a file and when I cat it back to
/dev/dsp, I get a jumbled set of disordered but recognizable chunks of
what I tried to record, and it all seems to be recorded at about the
CD-quality sample rate and word-size.  When I cat /dev/audio to a
file, then cat it back out, the result is "well-ordered" but telephone
quality, both for the optical digital in and the analog input on the
back of the card.  I have seen nothing on http://www.alsa-project.org/
to suggest that there is a known problem with recording from the
Optical Digital Input on the Audigy.


Version-Release number of selected component (if applicable): Fedora
Core 2 Test 3


How reproducible: Behaves same way for me every time


Steps to Reproduce:
1. Install Audigy 2 ZS hardware
2. Install Fedora Core 2 Test 3
3. Connect optical cable
4. Attempt to record
  
Actual results:
Krec: "position indicator" moves, and it seems to think it's recording
something.  No audio out on playback.  I can play pre-recorded audio
files through Krec.
SoundRecorder crashes when I press the reocrd button, but plays
pre-recorded sounds perfectly


Expected results:
I should be able to record from the optical digital in, and get at
least CD quality.


Additional info:
Comment 1 Dave Jones 2004-12-08 01:12:47 EST
is this any better with the current updates ?
Comment 2 Paul Tourville 2004-12-08 07:32:32 EST
I can now record with Sound Recorder and it doesn't crash, however I normally
record from optical with Glame (Glame has worked since the first set of kernel
updates after FC2-proper was released).

Thanks!

Paul

Note You need to log in before you can comment on or make changes to this bug.