Bug 121963 - Mistake in LVM2 initialization
Summary: Mistake in LVM2 initialization
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Blocker
TreeView+ depends on / blocked
 
Reported: 2004-04-29 11:37 UTC by Petr Krištof
Modified: 2014-03-17 02:44 UTC (History)
1 user (show)

Fixed In Version: 7.51-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-07 04:22:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rc.sysinit-lvm2.patch (508 bytes, patch)
2004-04-29 11:38 UTC, Petr Krištof
no flags Details | Diff
rc.sysinit-lvm3.patch (571 bytes, patch)
2004-05-06 13:07 UTC, Petr Krištof
no flags Details | Diff

Description Petr Krištof 2004-04-29 11:37:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
LVM2 init is done in rc.sysinit as:

# LVM2 initialization, take 2
        if [ -f /dev/mapper/control -a -x /sbin/lvm.static ]; then


It is wrong, because /dev/mapper/control is not regular file
but special control device.

This should be:

# LVM2 initialization, take 2
        if [ -e /dev/mapper/control -a -x /sbin/lvm.static ]; then



Version-Release number of selected component (if applicable):
initscripts-7.50-1

How reproducible:
Always

Steps to Reproduce:
Use LVM2 on raid.

Actual Results:  Logical volumes are not initialized after boot.

Expected Results:  Logical volumes must be initialized after boot.

Additional info:

IMHO it is the primary cause of many lvm or raid related bugs filled
in bugzilla.

Comment 1 Petr Krištof 2004-04-29 11:38:02 UTC
Created attachment 99771 [details]
rc.sysinit-lvm2.patch

Easy to fix.

Comment 2 Bill Nottingham 2004-05-03 21:16:26 UTC
Changed in 7.51-1 to -c /dev/....

Thanks!

Comment 3 Petr Krištof 2004-05-06 13:07:10 UTC
Created attachment 100043 [details]
rc.sysinit-lvm3.patch

The way you corrected it is better. BUT.
This fragment of code is in two different places in rc.sysinit script.
So I suggest to fix the another place too. :-)

Comment 4 Jeremy Katz 2004-05-07 04:22:07 UTC
Thanks, fixed


Note You need to log in before you can comment on or make changes to this bug.