Bug 1219630 - report hook stderr to Engine if it fails an action
Summary: report hook stderr to Engine if it fails an action
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Marcin Mirecki
QA Contact: Petr Kubica
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-07 20:12 UTC by Dan Kenigsberg
Modified: 2016-03-09 19:39 UTC (History)
10 users (show)

Fixed In Version: v4.17.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 19:39:29 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0362 normal SHIPPED_LIVE vdsm 3.6.0 bug fix and enhancement update 2016-03-09 23:49:32 UTC
oVirt gerrit 42592 master MERGED vdsm hooks: report hook stderr to Engine if it fails an action Never

Description Dan Kenigsberg 2015-05-07 20:12:35 UTC
When a before_* hook script returns 1, the calling action fails and reports an error code to Engine.

The "message" field reported with the error code should include the stderr of the hook, so that it is easier to discern the cause of the error from Engine event log alone.

Comment 2 Petr Kubica 2016-02-11 12:24:39 UTC
Verified in vdsm-4.17.19-0.el7ev.noarch
used: vdsm-hook-httpsisoboot-4.17.20-0.el7ev.noarch
- run VM from iso (https) with wrong address.

Comment 4 errata-xmlrpc 2016-03-09 19:39:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0362.html


Note You need to log in before you can comment on or make changes to this bug.