Bug 121974 - XF86Config ignored after FC2T3 install? stuck at 640x480
XF86Config ignored after FC2T3 install? stuck at 640x480
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
athlon Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-29 09:57 EDT by Maxwell Bottiger
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 02:27:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (30.26 KB, text/plain)
2004-04-29 20:04 EDT, Bryan White
no flags Details

  None (edit)
Description Maxwell Bottiger 2004-04-29 09:57:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
Well, my bug is pretty simialar to most of the Xorg bugs other people
have submitted, with the exception that my install appears to be
working.  (sort of)  I'm stuck at 640x480.  I can't change video modes
and any changes I make to XF86Config appear to be ignored.

I thought that maybe Xorg was looking for a different config file so I
started in run level 3 and tried running Xorg -configure
/etc/X11/XF86Config, but that didn't change anything. 
system-config-display shows the right monitor, the right video card,
and lets me choose differnt resolutions.  However, none of my choices
make difference, and gnome's screen resolution prefrences only let me
pick 640x480 @ 60hz.  I've even gone so far as to remove 640x480
entries from my config file, but that hasn't helped.

What's up with that?

Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-0.5

How reproducible:
Always

Steps to Reproduce:
1.upgrade from test2 to test3
2.boot in run level 5, or startx from run level 3
3.
    

Actual Results:  GDM and all Xwindows apps run like they're supposed
to, but at 640x480

Expected Results:  1200x1024

Additional info:

I have an ATI radeon 7000 and a dell 17" TFT monitor if that makes a
differnce.  I'm going to submit this as a high severity bug because
most of the software is unusable at this low resolution.
Comment 1 Bryan White 2004-04-29 20:04:28 EDT
Created attachment 99811 [details]
Xorg.0.log

Bugs 121946 and 121953 are duplicates of this one.

I've got two machines that exhibit the same problem.  A toshiba 1415 laptop and
Opteron system with a Nvidia 5700 and Sony GDM500PS CRT monitor.

What's weird is looking at the duplicate bugs and all the reports on the
fedora-test-list of the same problem... all the problems are with LCD
monitor/panels, except for my problem on the CRT monitor.

Things worked fine on FC2 on the laptop until about two weeks ago when I
resized the resolution to work on a different monitor.	The problem croped up
when I resized it back to work on the laptop's lcd panel. 

Attached is the Xorg.0.log logfile off of my laptop.
Comment 2 Francisco Javier Zaleta 2004-04-30 21:07:01 EDT
I had the same problem here...  However, I got it to work by 
changing /etc/X11/xorg.conf

Go down to "Section "Monitor"" and uncommend the 
HorizSync/VertRefresh lines so that you do not default to DDC.

Hope this helps someone.

Comment 3 Maxwell Bottiger 2004-05-01 00:09:59 EDT
Actually, I did the exact same thing earlier today, I think you just
posted a responce before me Francisco :)

I did indeed move XF86Config to xorg.conf but initally didn't change
any of the file settings.  I continued to have the problem of my
monitor loosing most of it's resolutions, so I decided to have a peek
at the log file.  The log said that most of the video modes were
skipped because they were out of my hsync range.

I have a Dell 1702FP, and system-config-display set my hsync range to
 31.1-39.0.  I changed it to 31.1-67.0  (the second value I just kinda
picked arbitrarily from another monitor) and voila, my screen came
back.  Since then the gnome screen resolution prefs and
system-config-display seem to work just fine.

So, in summary, changing the file name and uncommenting the
HorzSync/VertRefresh lines seems to do the trick.  I would only add
that it's a good idea to check out the values as they may not be right.

(does this mean the values for a Dell 1702FP are wrong in the monitor
database?)
Comment 4 Mike A. Harris 2004-05-04 14:08:20 EDT
The proper config file is /etc/X11/xorg.conf

Please ensure you are using that config file.  I am considering
removing the XF86Config file fallback support as it is more of a
hassle and source of confusion to users (and developers) than
anything.  That might help to make things less complicated, however
I'll need to have the XF86Config migrate to xorg.conf
Comment 5 Mike A. Harris 2004-10-01 02:27:03 EDT
The xorg that shipped in FC2, migrates XFree86 config files to
xorg.conf if detected and no xorg.conf exists already.

This problem should be resolved in Fedora Core 2 final release.

Note You need to log in before you can comment on or make changes to this bug.