Bug 121985 - raw fails: /dev/rawctl, no such device, but device exists
raw fails: /dev/rawctl, no such device, but device exists
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-04-29 11:12 EDT by Thorn Roby
Modified: 2015-01-04 17:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-02-02 16:48:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Thorn Roby 2004-04-29 11:12:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
Any raw operation produces the error
Cannot open master raw device '/dev/rawctl' (No such device or address)

The device exists (162,0) permissions 660 owner root. Making a symlink
as /dev/raw/rawctl makes no difference. Raw devices exist under /dev/raw.
Root is on LVM, boot on hda1.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. enter "raw -qa"

Actual Results:  Cannot open master raw device '/dev/rawctl' (No such
device or address)

Expected Results:  list raw devices

Additional info:
Comment 1 Thorn Roby 2004-04-29 11:55:08 EDT
I added a non-LVM SCSI drive and reproduced the same error, so it's
probably not related to device-mapper. I tried adding 

alias char-major-162 raw

to /etc/modprobe.conf as suggested in a posting by Andrew Morton with
no effect.
Comment 2 Thorn Roby 2004-04-30 13:15:52 EDT
I recompiled the kernel with CONFIG_RAW_DRIVER enabled and now the raw
command works (haven't actually tried the devices yet). From what I
can tell from mailing lists raw devices are deprecated in 2.6, but I
can't tell what's supposed to take their place. I see some comment
about opening devices using O_DIRECT but that's not an option if I'm
installing a 3rd party application that expects raw devices. And
what's the point of having the raw devices appear in /dev if the
shipped kernel can't access them?
Comment 3 Dave Jones 2004-12-08 01:14:45 EST
which 3rd party application doesn't support O_DIRECT out of curiousity ?
Comment 4 Thorn Roby 2004-12-08 12:49:41 EST
I was installing MySQL MaxDB (formerly SAPDB). It is possible that it does
support O_DIRECT, but the installation documentation refers to setting up raw
devices, and the only way I know how to do that is the raw interface. The fact
that the raw interface works properly, and as it did in 2.4, suggested to me
that the only solution was to compile it into the 2.6 kernel, which does work. I
still say that it's a bug to present the raw devices in the file system if they
are deprecated and unusable without a kernel rebuild, but perhaps their presence
makes it easier to add the functionality.
Part of my confusion here is that I really don't know where all this stuff
should be documented. I understand that the distribution documentation can't
cover every obscure aspect of the kernel or other functionality, and that raw
devices aren't used a lot. Maybe it's just a question of including it in the
release notes.
Comment 5 Mark Wormgoor 2004-12-21 09:07:33 EST
If rawdevices is deprecated (I want to use it for Xine to allow raw
access as suggested in the xine FAQ), what is the purpose of
/etc/init.d/rawdevices and /etc/sysconfig/rawdevices?

If I add a device to /etc/sysconfig rawdevices and do
/etc/init.d/rawdevices start, I get this:
Assigning devices:
           /dev/raw/raw1  -->   /dev/dvd
Cannot open master raw device '/dev/rawctl' (No such device or address)
Comment 6 Dave Jones 2005-01-11 00:09:02 EST
as the raw driver was enabled in FC2 at time it was shipped, I'll reenable it
for the next FC2 kernel update.
Comment 7 Thorn Roby 2005-01-11 12:17:57 EST
Can you enable it in FC3 also?
Comment 8 Dave Jones 2005-01-11 13:19:43 EST
no. this is marked as deprecated for some time now, and could go away completely
at any point in a kernel update.

Note You need to log in before you can comment on or make changes to this bug.