Bug 1219922 - segfaults if I press ESC
Summary: segfaults if I press ESC
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: audacity
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: David Timms
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-08 18:01 UTC by Sami Farin
Modified: 2015-12-22 22:07 UTC (History)
3 users (show)

Fixed In Version: audacity-2.1.1-1.fc21 audacity-2.1.2-0.7.rc1.fc22 audacity-2.1.2-0.7.rc1.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-18 09:58:57 UTC
Type: Bug


Attachments (Terms of Use)

Description Sami Farin 2015-05-08 18:01:36 UTC
Description of problem:
if I press ESC when in file save prompt etc:

Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x00007f0380ba9f40 in g_type_check_instance_cast () from /lib64/libgobject-2.0.so.0
(gdb) bt
#0  0x00007f0380ba9f40 in g_type_check_instance_cast () at /lib64/libgobject-2.0.so.0
#1  0x00007f037ee3553f in wxDialog::ShowModal() () at /lib64/libwx_gtk2u_core-2.8.so.0
#2  0x0000000000849a35 in FileDialog::ShowModal() (this=this@entry=0x7ffdf4846880) at gtk/FileDialogPrivate.cpp:307
#3  0x00000000008484f4 in FileSelector(wxString const&, wxString const&, wxString const&, wxString const&, wxString const&, int, wxWindow*) (title=..., defaultDir=..., defaultFileName=..., defaultExtension=..., filter=..., flags=66, parent=0x3005660) at FileDialog.cpp:108
#4  0x00000000006152fa in AudacityProject::SaveAs(bool) (this=this@entry=0x3005660, bWantSaveCompressed=bWantSaveCompressed@entry=false) at Project.cpp:3727
#5  0x0000000000615f5b in AudacityProject::Save(bool, bool, bool) (this=this@entry=0x3005660, overwrite=overwrite@entry=true, fromSaveAs=fromSaveAs@entry=false, bWantSaveCompressed=bWantSaveCompressed@entry=false) at Project.cpp:3227
#6  0x000000000061a32e in AudacityProject::OnCloseWindow(wxCloseEvent&) (this=0x3005660, event=...) at Project.cpp:2034
#7  0x00007f037e53238c in wxEvtHandler::ProcessEventIfMatches(wxEventTableEntryBase const&, wxEvtHandler*, wxEvent&) () at /lib64/libwx_baseu-2.8.so.0
#8  0x00007f037e532443 in wxEventHashTable::HandleEvent(wxEvent&, wxEvtHandler*) () at /lib64/libwx_baseu-2.8.so.0
#9  0x00007f037e5327eb in wxEvtHandler::ProcessEvent(wxEvent&) () at /lib64/libwx_baseu-2.8.so.0
#10 0x00007f037eeea2fc in wxWindowBase::Close(bool) () at /lib64/libwx_gtk2u_core-2.8.so.0
#11 0x000000000056a481 in QuitAudacity() (bForce=false) at AudacityApp.cpp:267
#12 0x000000000056a481 in QuitAudacity() () at AudacityApp.cpp:311
#13 0x00000000006a41ae in CommandManager::HandleKey(wxKeyEvent&, unsigned int, unsigned int) (evt=<optimized out>, mask=<optimized out>, flags=<optimized out>, entry=<optimized out>, this=<optimized out>) at commands/CommandManager.cpp:1036
#14 0x00000000006a41ae in CommandManager::HandleKey(wxKeyEvent&, unsigned int, unsigned int) (this=this@entry=0x3005ae0, evt=..., flags=374389421, mask=mask@entry=4294967295) at commands/CommandManager.cpp:1063
#15 0x000000000060e1e8 in AudacityProject::HandleKeyDown(wxKeyEvent&) (this=0x3005660, event=...) at Project.cpp:1829
#16 0x000000000056947d in AudacityApp::OnKeyDown(wxKeyEvent&) (this=<optimized out>, event=...) at AudacityApp.cpp:1820
#17 0x00007f037e53238c in wxEvtHandler::ProcessEventIfMatches(wxEventTableEntryBase const&, wxEvtHandler*, wxEvent&) () at /lib64/libwx_baseu-2.8.so.0
#18 0x00007f037e532443 in wxEventHashTable::HandleEvent(wxEvent&, wxEvtHandler*) () at /lib64/libwx_baseu-2.8.so.0
#19 0x00007f037e5327eb in wxEvtHandler::ProcessEvent(wxEvent&) () at /lib64/libwx_baseu-2.8.so.0
#20 0x00007f037edf579f in gtk_window_key_press_callback () at /lib64/libwx_gtk2u_core-2.8.so.0
#21 0x00007f037cb5f82d in _gtk_marshal_BOOLEAN__BOXED (closure=0x3506f40, return_value=0x7ffdf48479c0, n_param_values=<optimized out>, param_values=0x7ffdf4847a20, invocation_hint=<optimized out>, marshal_data=<optimized out>) at gtkmarshalers.c:86
#22 0x00007f0380b82705 in g_closure_invoke () at /lib64/libgobject-2.0.so.0
#23 0x00007f0380b94cf9 in signal_emit_unlocked_R () at /lib64/libgobject-2.0.so.0
#24 0x00007f0380b9eab2 in g_signal_emit_valist () at /lib64/libgobject-2.0.so.0
#25 0x00007f0380b9f2f7 in g_signal_emit () at /lib64/libgobject-2.0.so.0
#26 0x00007f037cc8f1bc in gtk_widget_event_internal (widget=widget@entry=0x3457580, event=event@entry=0x33d2110) at gtkwidget.c:5017
#27 0x00007f037cc8f4b1 in IA__gtk_widget_event (widget=widget@entry=0x3457580, event=event@entry=0x33d2110) at gtkwidget.c:4814
#28 0x00007f037cca4a2b in IA__gtk_window_propagate_key_event (window=window@entry=0x2b44270, event=event@entry=0x33d2110) at gtkwindow.c:5199
#29 0x00007f037cca75b3 in gtk_window_key_press_event (widget=0x2b44270, event=0x33d2110) at gtkwindow.c:5229
#30 0x00007f037cb5f82d in _gtk_marshal_BOOLEAN__BOXED (closure=0x2b39540, return_value=0x7ffdf4847f10, n_param_values=<optimized out>, param_values=0x7ffdf4847f80, invocation_hint=<optimized out>, marshal_data=<optimized out>) at gtkmarshalers.c:86
#31 0x00007f0380b82705 in g_closure_invoke () at /lib64/libgobject-2.0.so.0
#32 0x00007f0380b9551f in signal_emit_unlocked_R () at /lib64/libgobject-2.0.so.0
#33 0x00007f0380b9eab2 in g_signal_emit_valist () at /lib64/libgobject-2.0.so.0
#34 0x00007f0380b9f2f7 in g_signal_emit () at /lib64/libgobject-2.0.so.0
#35 0x00007f037cc8f1bc in gtk_widget_event_internal (widget=widget@entry=0x2b44270, event=event@entry=0x33d2110) at gtkwidget.c:5017
#36 0x00007f037cc8f4b1 in IA__gtk_widget_event (widget=widget@entry=0x2b44270, event=event@entry=0x33d2110) at gtkwidget.c:4814
#37 0x00007f037cb5dbaf in IA__gtk_propagate_event (widget=0x2b44270, event=0x33d2110) at gtkmain.c:2475
#38 0x00007f037cb5df7b in IA__gtk_main_do_event (event=0x33d2110) at gtkmain.c:1696
#39 0x00007f037c7b664c in gdk_event_dispatch (source=<optimized out>, callback=<optimized out>, user_data=<optimized out>) at gdkevents-x11.c:2425
#40 0x00007f037b87186a in g_main_context_dispatch (context=0x2ab9a30) at gmain.c:3122
#41 0x00007f037b87186a in g_main_context_dispatch (context=context@entry=0x2ab9a30) at gmain.c:3737
#42 0x00007f037b871c10 in g_main_context_iterate (context=0x2ab9a30, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3808
#43 0x00007f037b871f32 in g_main_loop_run (loop=0x35eaee0) at gmain.c:4002
#44 0x00007f037cb5cec7 in IA__gtk_main () at gtkmain.c:1268
#45 0x00007f037ede0dea in wxEventLoop::Run() () at /lib64/libwx_gtk2u_core-2.8.so.0
#46 0x00007f037ee6c22a in wxAppBase::MainLoop() () at /lib64/libwx_gtk2u_core-2.8.so.0
#47 0x00007f037e4d962a in wxEntry(int&, wchar_t**) () at /lib64/libwx_baseu-2.8.so.0
#48 0x0000000000517672 in main(int, char**) (argc=2, argv=<optimized out>) at AudacityApp.cpp:637
(gdb) q


Version-Release number of selected component (if applicable):
2.1.0

How reproducible:
always

Steps to Reproduce:
1. save file
2. press esc
3.

Actual results:
segfault

Expected results:
saving file

Additional info:
glib2-2.45.1
wxGTK-2.8.12-16

Comment 1 David Timms 2015-05-22 08:46:20 UTC
Hi Sami: 
Does it occur every time you try it ?

Are you using the mouse to select File|Save Project ?

Do you get the Warning "saving as audacity project" ?

If a user was pressing esc, do you think they would be intending to close the dialogue without saving (i.e. the expected result is to not save the file) ?

32/64 bit audacity on which kernel ?

By "etc:" do you mean this occurs in other dialogues as well (which ones) ?

Comment 2 Sami Farin 2015-05-22 09:04:35 UTC
>Does it occur every time you try it ?

Yes

>Are you using the mouse to select File|Save Project ?

Crashes when I use mouse or keyboard

>Do you get the Warning "saving as audacity project" ?

No

>If a user was pressing esc, do you think they would be intending to close the dialogue without saving (i.e. the expected result is to not save the file) ?

Irrelevant

>32/64 bit audacity on which kernel ?

64 bit, 4.0.4

>By "etc:" do you mean this occurs in other dialogues as well (which ones) ?

Well, I didn't find other crashing dialogues.

BTW if I select Cancel instead of pressing Esc, it does not crash.

Comment 3 David Timms 2015-05-24 22:04:30 UTC
I see some assertions: Glib-GObject, Gtk-CRITICAL, but no crash. 
I have glib2-2.44.1-1, kernel 4.0.2.
Where is glib2-2.45.1 from ?

Can you try with same glib2/kernel that I'm on ?

Comment 4 Sami Farin 2015-05-25 06:55:27 UTC
does not crash with f21 latest version 2.42.2, but:

(Audacity:4641): GLib-GObject-WARNING **: invalid unclassed pointer in cast to 'GtkWindow'

(Audacity:4641): Gtk-CRITICAL **: IA__gtk_window_set_modal: assertion 'GTK_IS_WINDOW (window)' failed

Comment 5 Fedora Admin XMLRPC Client 2015-06-12 13:11:14 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 6 Fedora Update System 2015-06-29 13:27:32 UTC
audacity-2.1.1-0.1.dea351a.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/audacity-2.1.1-0.1.dea351a.fc22

Comment 7 Sami Farin 2015-07-02 07:40:08 UTC
dea351a does not start unless I manually create directory /var/tmp/audacity-safari , it only silently exits.

It also segfaults if I press esc in save dialog.

Comment 8 Fedora Update System 2015-07-05 04:23:28 UTC
audacity-2.1.1-0.2.rc1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/audacity-2.1.1-0.2.rc1.fc22

Comment 9 Fedora Update System 2015-07-05 04:23:44 UTC
audacity-2.1.1-0.2.rc1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/audacity-2.1.1-0.2.rc1.fc21

Comment 10 Fedora Update System 2015-07-12 22:44:16 UTC
audacity-2.1.1-0.4.rc3.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/audacity-2.1.1-0.4.rc3.fc22

Comment 11 Fedora Update System 2015-07-12 22:44:32 UTC
audacity-2.1.1-0.4.rc3.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/audacity-2.1.1-0.4.rc3.fc21

Comment 12 Fedora Update System 2015-07-14 15:28:36 UTC
Package audacity-2.1.1-0.4.rc3.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing audacity-2.1.1-0.4.rc3.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-11488/audacity-2.1.1-0.4.rc3.fc22
then log in and leave karma (feedback).

Comment 13 Fedora Update System 2015-07-19 09:04:37 UTC
audacity-2.1.1-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/audacity-2.1.1-1.fc22

Comment 14 Fedora Update System 2015-07-19 09:06:27 UTC
audacity-2.1.1-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/audacity-2.1.1-1.fc21

Comment 15 Fedora Update System 2015-07-30 01:16:06 UTC
audacity-2.1.1-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Sami Farin 2015-07-30 08:07:29 UTC
With glib2-2.45.4 I get the segfault.

Comment 17 Fedora Update System 2015-08-01 02:29:18 UTC
audacity-2.1.1-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 David Timms 2015-08-02 21:37:25 UTC
(In reply to Sami Farin from comment #16)
> With glib2-2.45.4 I get the segfault.
Since I am unable to reproduce this, can you please provide the results of:
$ rpm -q audacity audacity-freeworld kernel glib2 gtk3 wxGTK wxGTK3

eg. I'm now on the below, but don't see this.
audacity-2.1.1-1.fc22.x86_64
package audacity-freeworld is not installed
kernel-4.0.8-300.fc22.x86_64
kernel-4.1.2-200.fc22.x86_64
kernel-4.1.3-200.fc22.x86_64
glib2-2.44.1-1.fc22.x86_64
glib2-2.44.1-1.fc22.i686
gtk3-3.16.6-1.fc22.x86_64
wxGTK-2.8.12-16.fc22.x86_64
wxGTK3-3.0.2-8.fc22.x86_64

Comment 19 Sami Farin 2015-08-02 21:51:55 UTC
same as you, except glib2-2.45.4, and kernel does not matter in this case (4.2.0-rc4)

But I'd guess also next stable glib2 2.46 would crash, if 2.45 crashes..

Comment 20 David Timms 2015-08-03 11:19:11 UTC
You might have missed the too subtle: where is your glib2 from... is it packaged, is it rawhide, is it hand compiled ?

If it is rawhide, I think you may need to run audacity from rawhide as well... (which brings in just about the whole shebang anyway).

Comment 21 Fedora Update System 2015-11-21 12:17:27 UTC
audacity-2.1.2-0.7.rc1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-51664dda77

Comment 22 Fedora Update System 2015-12-04 10:59:19 UTC
audacity-2.1.2-0.7.rc1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-4320723725

Comment 23 Fedora Update System 2015-12-04 17:20:22 UTC
audacity-2.1.2-0.7.rc1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update audacity'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-4320723725

Comment 24 Fedora Update System 2015-12-18 09:58:42 UTC
audacity-2.1.2-0.7.rc1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 25 Fedora Update System 2015-12-22 22:07:22 UTC
audacity-2.1.2-0.7.rc1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.