Bug 121995 - X Crashes On Startup Inspiron 8000 ATI Rage Mobility M4
X Crashes On Startup Inspiron 8000 ATI Rage Mobility M4
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-29 12:40 EDT by Robert Williams
Modified: 2017-01-10 22:18 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 02:28:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Certification Workflow Engine(Live) 121995 None None None 2017-01-10 22:18 EST

  None (edit)
Description Robert Williams 2004-04-29 12:40:49 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, 
like Gecko) 
 
Description of problem: 
I have the 1600x1200 screen and the ATI Rage Mobility M4 graphics 
card. During the install process on both test2 and test3 I have a 
weird line down the middle of the screen that has garbage in it. 
 
During the reboot after the install the during first-time configure 
the screen is completly messed up. IE three half copies of the screen 
on my monitor. I set my screen resolution to 1600x1200 reboot and X 
won't start. 
 
I manually edited XF86Config to try and use just the vesa driver but 
X still won't boot. 
 
 
How reproducible: 
Always
Comment 1 Robert Williams 2004-04-29 12:54:42 EDT
I had a stupid little mistake in my xorg.conf file i typed in vsea 
not vesa. It work now with using the vesa driver. 
Comment 2 Mike A. Harris 2004-05-04 13:59:24 EDT
Fedora Core 2 test 3 does not ship with XFree86.  We have replaced
XFree86 with X.org X11 in test2 and later releases.  The new X
server is named "Xorg" and uses the config file /etc/X11/xorg.conf

Please ensure your system is updated to the latest updates from
rawhide, and then attach your /var/log/Xorg.0.log logfile and your
xorg.conf config file as individual uncompressed file attachments
using the bugzilla link below, and I will review them for
troubleshooting.

Thanks in advance.
Comment 3 Mike A. Harris 2004-05-04 14:03:52 EDT
I forgot to mention... for the above, first run:

system-config-display --reconfig

Then startx with the generated config file.
Comment 4 Richard Hoelscher 2004-05-10 15:44:32 EDT
I'm also seeing this problem. (Dell Inspiron 8000, ATI Rage Mobility 
M4, 1600x1200)... From the 'hardware' section of the display tool, I 
have "Dell 1600x1200 Laptop Display Panel" selected.

To fix, I had to go into xorg.conf, and uncomment the lines 
after "### Uncomment if you don't want to default to DDC":
HorizSync 31.5 - 90
VertRefresh 59.0 - 85.0

After that, it worked fine.
Comment 5 Jason Perkins 2004-05-20 16:25:18 EDT
I had the same problem...I fixed it by manually changing the color
depth from 24 to 16. Now running fine at 1400x1050.
Comment 6 Linh Giang 2004-09-20 22:15:07 EDT
Still having problem.

I looked into the xorg.conf, but couldn't find "Uncomment if you don't
wan tto default to DDC" line.

Reducing color depth from 24 to 16 works, but I prefer keeping at 24.
I work extensively with graphics.

Comment 7 Mike A. Harris 2004-10-01 02:28:01 EDT
This issue was resolved in the final release of Fedora Core 2.

Setting status to "CURRENTRELEASE"

Note You need to log in before you can comment on or make changes to this bug.