Bug 121999 - make xconfig unusable because of a unreadable symbol font
make xconfig unusable because of a unreadable symbol font
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-29 12:56 EDT by Michael Opdenacker
Modified: 2015-01-04 17:05 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-08 10:51:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Opdenacker 2004-04-29 12:56:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040422

Description of problem:
Hello,

I made a fresh install of FC2 T3 with all
packages installed (including all languages)

I tried to recompile the kernel, but "make xconfig"
is unusable because of a unreadable symbol font.

See http://michaelo.free.fr/issues/xconfig_apr29_2004/xconfig.png

A workaround is to use "make menuconfig" instead,
but this is not as user friendly as "make xconfig".

I'm using the GNOME desktop and my LANG environment
variable is set to "en_US.UTF-8".

Note that this happened in FC2 T2 too.

Don't hesitate to ask me for more details!

Cheers,

Michael.

Version-Release number of selected component (if applicable):
kernel-2.6.5-1.327

How reproducible:
Always

Steps to Reproduce:
1. Make sure the kernel-source package is installed
2. cd /usr/src/linux-2.6.5-1.327
3. make xconfig
    

Additional info:
Comment 1 Arjan van de Ven 2004-04-29 13:01:58 EDT
ok the big question is if any other QT app has broken fonts; since all
make xconfig does is use the QT libary.

(sidenote: there is also make gconfig with a gtk/gnome variant of make
xconfig)
Comment 2 Sammy 2004-04-30 09:37:59 EDT
No.....I have been having the same problem for a long time too. All other QT 
stuff work fine. 
 
SOLUTION for me is to edit the highest level Makefile, look for LANG and 
LC_ALL, remove the little if-then-else block and explicitly set LANG and 
LC_ALL to En_US.UTF-8. This suggests to me that the problem is with 
picking up these environment variables. My /etc/sysconfig/i18n is: 
 
LANG="en_US.UTF-8" 
SUPPORTED="en_US.UTF-8:en_US:en" 
SYSFONT="latarcyrheb-sun16" 
# 
Comment 3 Sammy 2004-04-30 09:38:35 EDT
No.....I have been having the same problem for a long time too. All other QT 
stuff work fine. 
 
SOLUTION for me is to edit the highest level Makefile, look for LANG and 
LC_ALL, remove the little if-then-else block and explicitly set LANG and 
LC_ALL to En_US.UTF-8. This suggests to me that the problem is with 
picking up these environment variables. My /etc/sysconfig/i18n is: 
 
LANG="en_US.UTF-8" 
SUPPORTED="en_US.UTF-8:en_US:en" 
SYSFONT="latarcyrheb-sun16" 
# 
Comment 4 Michael Opdenacker 2004-05-11 04:16:30 EDT
Just to note that this still happens with the sources
of the latest kernel: Linux 2.6.5-1.358
Comment 5 Sammy 2004-05-11 12:31:13 EDT
The problem is happening becaue LC_ALL is not set by the 
/etc/profile.d/lang.sh script. It sets LANG but not LC_ALL. 
As a matter of fact it unsets LC_ALL if it is equal to LANG. 
I am not sure what the difference between LANG and 
LC_ALL are supposed to be. 
 
arjan: Please forward to initscripts if this is a bug. 
Comment 6 Bill Nottingham 2004-05-19 18:00:06 EDT
LC_ALL should generally not need to be set.

LC_* inherits from LANG if they aren't set.

So, what the makefile is doing is setting LC_CTYPE and LC_COLLATE to
C, but leaves LANG as normal. That really isn't right.

Does it work if you remove that block entirely?
Comment 7 Ian Amess 2004-05-24 05:19:52 EDT
Another work around is to run ./scripts/kconfig/qconf
arch/$ARCH/Kconfig this will display correctly.
In my case make xconfig is looking for the following fonts 

XFT_DEBUG=1
#
# using defaults found in .config
#
XftFontInfoFill: /usr/share/fonts/hebrew/Caladings.pfa: 0 (13 pixels)
XftFontInfoFill: /usr/share/fonts/hebrew/Caladings.pfa: 0 (16 pixels)
XftFontInfoFill: /usr/share/fonts/hebrew/Caladings.pfa: 0 (16 pixels)

where as running qconf looks for 

XFT_DEBUG=1
#
# using defaults found in .config
#
XftFontInfoFill: /usr/X11R6/lib/X11/fonts/Type1/l048013t.pfa: 0 (13
pixels)
XftFontInfoFill: /usr/X11R6/lib/X11/fonts/Type1/l048013t.pfa: 0 (16
pixels)
XftFontInfoFill: /usr/X11R6/lib/X11/fonts/Type1/l048016t.pfa: 0 (16
pixels)

Hope this helps to shed mor light.

Comment 8 Dave Jones 2004-12-08 01:16:23 EST
this still a problem with the latest updates ?
Comment 9 Michael Opdenacker 2004-12-08 07:54:28 EST
No, this bug can be closed.
It was fixed in mainstream Linux 2.6.8 IIRC.

Thanks for asking!

:-)

Michael.

Note You need to log in before you can comment on or make changes to this bug.