Bug 1219997 - ipython in pylab qt mode prevents import of PyQt4
Summary: ipython in pylab qt mode prevents import of PyQt4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ipython
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Thomas Spura
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-09 01:09 UTC by Christian Lupien
Modified: 2015-07-30 01:18 UTC (History)
6 users (show)

Fixed In Version: ipython-2.4.1-7.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-30 00:46:28 UTC
Type: Bug


Attachments (Terms of Use)

Description Christian Lupien 2015-05-09 01:09:13 UTC
Description of problem:
Trying to import PyQt4 in a pylab session of ipython fails.

Version-Release number of selected component (if applicable):
python-ipython-2.4.1-1.fc21.noarch

How reproducible:
Always

Steps to Reproduce:
1. Start ipython in pylab mode: ipython --pylab=qt
2. Try to import pyQt4

Actual results:
ImportError: 
    Importing PyQt4 disabled by IPython, which has
    already imported an Incompatible QT Binding: pyqtv1


Expected results:
It should just import the module. It is already loaded.

Additional info:
The problem is a bug in IPython version 2.4.1
The fix is in 3.0.0.
The actual commit of the fix is 
 https://github.com/ipython/ipython/commit/5f275fe135362d5b6cca79d004f8fa272eec24d2

So please either update ipython or backport the small fix.

Comment 1 Fedora Update System 2015-05-09 04:08:17 UTC
ipython-2.4.1-3.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/ipython-2.4.1-3.fc21

Comment 2 Christian Lupien 2015-05-11 19:51:19 UTC
I just updated to python-ipython-2.4.1-3.fc21.noarch from update-testing and it works. My problem is solved. Thanks.

Comment 3 Fedora Update System 2015-05-12 20:46:01 UTC
Package ipython-2.4.1-5.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ipython-2.4.1-5.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-7900/ipython-2.4.1-5.fc21
then log in and leave karma (feedback).

Comment 4 Christian Lupien 2015-05-13 15:37:16 UTC
The install line should be
 su -c 'yum update --enablerepo=updates-testing python-ipython-2.4.1-5.fc21'

It works for me. I left some karma.

Comment 5 Fedora Update System 2015-07-14 15:28:06 UTC
Package ipython-2.4.1-6.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ipython-2.4.1-6.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-7900/ipython-2.4.1-6.fc21
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2015-07-16 15:34:23 UTC
ipython-2.4.1-7.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/ipython-2.4.1-7.fc21

Comment 7 Fedora Update System 2015-07-16 15:34:35 UTC
ipython-2.4.1-7.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/ipython-2.4.1-7.fc22

Comment 8 Fedora Update System 2015-07-18 01:55:33 UTC
Package ipython-2.4.1-7.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ipython-2.4.1-7.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-11677/ipython-2.4.1-7.fc22
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2015-07-30 00:46:28 UTC
ipython-2.4.1-7.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2015-07-30 01:18:47 UTC
ipython-2.4.1-7.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.