Bug 122014 - touchpad on laptop does not respond to tapping
touchpad on laptop does not respond to tapping
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-29 14:58 EDT by Mark Lucia
Modified: 2015-01-04 17:05 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 01:50:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Lucia 2004-04-29 14:58:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
The touchpad on my laptop doesn't respond to tapping, as it did with
RH8 and RH9. I first noticed this on test1, but assumed it was my
ignorance. I've re-installed 9 a few times, and that problem never
surfaced... this time with test3, I was bright enough to save
/etc/X11/XF86config from the 9 installation, and tried changing the
mouse section to reflect what was saved from rh9.... however, the
problem persists.

In short, I must use the buttons on the laptop, and cannot single or
double tap the touchpad to select etc.

BTW - Dell inspiron 8100

tnx

Version-Release number of selected component (if applicable):
since test1

How reproducible:
Always

Steps to Reproduce:
1. install Fedora
2. use the touchpad
3.
    

Actual Results:  I cannot select etc by tapping on the touchpad

Additional info:

This is a non-starter for me, the the reason I went back to rh9 after
trying test1 on this laptop.
Comment 1 Aaron Bennett 2004-04-29 16:33:18 EDT
Same issue happens on a Dell C640 and on a Dell D600.  The touchpad is
by synaptics.
Comment 2 Richard Henderson 2004-04-29 22:37:34 EDT
Similarly for an IBM ThinkPad T41.  Relevant dmesg output is

serio: i8042 AUX port at 0x60,0x64 irq 12
Synaptics Touchpad, model: 1
 Firmware: 5.9
 Sensor: 44
 new absolute packet format
 Touchpad has extended capability bits
 -> multifinger detection
 -> palm detection
 -> pass-through port
input: SynPS/2 Synaptics TouchPad on isa0060/serio1
serio: Synaptics pass-through port at isa0060/serio1/input0
input: PS/2 Generic Mouse on synaptics-pt/serio0
serio: i8042 KBD port at 0x60,0x64 irq 1
input: AT Translated Set 2 keyboard on isa0060/serio0

I don't think this is an X issue at all; similar lack of tap
can be seen from gpm on the console.  I assume the problem is
in the kernel driver that both X and gpm are reading.
Comment 3 Mike A. Harris 2004-05-04 14:09:29 EDT
Reassigning to kernel component.
Comment 4 Darin May 2004-05-12 14:16:41 EDT
Have an HP Omnibook 4150b w/touchpad enabled and touchpoint disabled.
 For the first time ever tapping worked, I rebooted and it didn't. 
While it was working, I didn't check the mouse control panel to see if
there was some option to reflect its state (don't know if there is or
should be).
Comment 5 Aaron Bennett 2004-05-13 17:17:48 EDT
Arjan,

Could you post an update about this?  I consider it a fairly critical
bug and it's disturbing to have no updates as the release of FC2
approaches. 

Will this bug be fixed in FC2?
Comment 6 Mike Becker 2004-05-22 20:28:20 EDT
For what it's worth, I have this same problem on my Gateway M500,
which uses a Synaptics Touchpad,  I correct this problem, however, by
adding this command to the GRUB's kernel line:

psmouse.proto=imps

You can also use it during the installation phase by using this
command at the prompt:

linux psmouse.proto=imps

I found this 'fix' at the Mandrake forum as it is used for the Mdk 10
Comm. distro and it 'seems' to work with any distro using the 2.6
kernel.  

Since I am not a programmer, I have no idea why this works, just that
it does!
Comment 7 Mike Becker 2004-05-22 20:31:38 EDT
I should have added - I'm using FC2 and the above command has worked
for me since FC2-Test2...
Comment 8 Richard Henderson 2004-05-23 14:18:24 EDT
This works by disabling the Synaptics driver.  You can see this
in the boot logs.

However...  On the ThinkPad T series there are five buttons around
the trackpad, three above and two below.  The three above appear to
be associated with the eraserhead pointer thingy rather than the
trackpad itself, and with the =imps command line option both the
eraserhead and the top three buttons are non-functional.

This is most unfortunate because I find the top three buttons easiser
to use than the bottom two wrt thumb placement.  Also, having a true
middle-mouse button for pasting eliminates scores of emulate-middle-
mouse timing errors on my part.
Comment 9 Dmitry Torokhov 2004-06-02 10:01:49 EDT
Fedora team really needs to package Peter Osterlund's native 
synaptics driver for X. It does tapping and everything else. 
Considering that you have updated GPM that supports event device, X 
driver is the last piece that is missing.
Comment 10 Arjan van de Ven 2004-06-09 06:00:21 EDT
Can people on this bug please try the latest 424 kernel from
http://people.redhat.com/arjanv/2.6 
it has a bunch of touchpad fixes, including one that's supposed to
make tapping work again
Comment 11 Richard Henderson 2004-06-09 13:02:25 EDT
No change on the IBM T41.
Comment 12 Mark Lucia 2004-07-15 14:07:16 EDT
The 424 kernel alone doesn't change the problem... adding
psmouse.proto=imps to the kernel line in /etc/grub.conf fixes it however.

I think it requires both. 

TNX - mlucia
Comment 13 Dave Jones 2004-12-07 00:55:00 EST
any improvement with the 2.6.9 update kernel ?
Comment 14 Richard Henderson 2004-12-07 01:36:29 EST
I upgraded to fc3, and everything *does* work there.  That's with the
original fc3 dist kernel and the updates.
Comment 15 Mike A. Harris 2004-12-07 01:50:47 EST
> Fedora team really needs to package Peter Osterlund's native 
> synaptics driver for X. It does tapping and everything else. 
> Considering that you have updated GPM that supports event device, X 
> driver is the last piece that is missing.

synaptics-0.13.5-5 is in Fedora Core 3

I think this entire bug report is due to the 2.6.x kernel input layer no
longer working the same way the 2.4.x one did.  This required touchpad
users to have to use the synaptics driver to get all of the functionality
they previously did not need.

In Fedora Core 2, we did not provide synaptics, so that functionality
is officially unsupported in FC2.  For FC3, we do however, which is
my current assumption as to why this problem has went away.

Short term workaround for FC2 users:  Download the FC3 'synaptics' src.rpm
and rebuild it for FC2, and install that.

Short and long term solution: Upgrade to FC3 or later and use 'synaptics'
driver that comes with the OS.

Since I think the problem has been isolated here, I'm going to close
this as being fixed in "CURRENTRELEASE" (FC3) as per comment #14 along with
my above explanation.

Note You need to log in before you can comment on or make changes to this bug.