Bug 1220152 - [hosted-engine-setup] [FC support] Deployment fails because the hosted engine VM disk fails to be added to the engine DB
Summary: [hosted-engine-setup] [FC support] Deployment fails because the hosted engine...
Keywords:
Status: CLOSED DUPLICATE of bug 1215623
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-hosted-engine-setup
Version: 3.6
Hardware: x86_64
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Sandro Bonazzola
QA Contact: Elad
URL:
Whiteboard: integration
Depends On:
Blocks: 1036731 1153278
TreeView+ depends on / blocked
 
Reported: 2015-05-10 13:40 UTC by Elad
Modified: 2015-05-11 10:48 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-11 10:48:20 UTC
oVirt Team: ---


Attachments (Terms of Use)
/var/log from the host (3.65 MB, application/x-gzip)
2015-05-10 13:40 UTC, Elad
no flags Details

Description Elad 2015-05-10 13:40:42 UTC
Created attachment 1023990 [details]
/var/log from the host

Description of problem:
I deployed hosted engine over FC. The deployment failed because the hosted engine VM disk failed to be added to the engine DB:

20**FILTERED**5-05-**FILTERED**0 **FILTERED**2:49:24 DEBUG otopi.plugins.ovirt_hosted_engine_setup.engine.add_disk add_disk._closeup:**FILTERED**99 Cannot add the Hosted Engine VM Disk to t
he engine
Traceback (most recent call last):
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/engine/add_disk.py", line **FILTERED**95, in _closeup
    engine_api.disks.add(disk)
  File "/usr/lib/python2.7/site-packages/ovirtsdk/infrastructure/brokers.py", line **FILTERED**0357, in add
    headers={"Expect":expect, "Correlation-Id":correlation_id}
  File "/usr/lib/python2.7/site-packages/ovirtsdk/infrastructure/proxy.py", line 75, in add
    return self.request('POST', url, body, headers)
  File "/usr/lib/python2.7/site-packages/ovirtsdk/infrastructure/proxy.py", line **FILTERED**5, in request
    persistent_auth=self.__persistent_auth
  File "/usr/lib/python2.7/site-packages/ovirtsdk/infrastructure/connectionspool.py", line 79, in do_request
    persistent_auth)
  File "/usr/lib/python2.7/site-packages/ovirtsdk/infrastructure/connectionspool.py", line **FILTERED**55, in __do_request
    raise errors.RequestError(response_code, response_reason, response_body)
RequestError: 
status: 500
reason: Internal
detail: HTTP Status 500
20**FILTERED**5-05-**FILTERED**0 **FILTERED**2:49:24 ERROR otopi.plugins.ovirt_hosted_engine_setup.engine.add_disk add_disk._closeup:202 Cannot add the Hosted Engine VM Disk to the engine
20**FILTERED**5-05-**FILTERED**0 **FILTERED**2:49:24 DEBUG otopi.context context._executeMethod:**FILTERED**55 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/otopi/context.py", line **FILTERED**45, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/engine/add_disk.py", line 205, in _closeup
    _('Cannot add the Hosted Engine VM Disk to the engine')
RuntimeError: Cannot add the Hosted Engine VM Disk to the engine
20**FILTERED**5-05-**FILTERED**0 **FILTERED**2:49:24 ERROR otopi.context context._executeMethod:**FILTERED**64 Failed to execute stage 'Closing up': Cannot add the Hosted Engine VM Disk to 
the engine


Version-Release number of selected component (if applicable):
ovirt-3.6.0-1 
ovirt-hosted-engine-setup-1.3.0-0.0.master.20150401110307.git9665976.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. Deploy hosted-engine over FC

Actual results:
After the engine is up, engine health status finished and the host was initialized in the DC, the deployment failed with the error mentioned above

Expected results:
Engine VM disk should be added successfully, the deployment should succeed

Additional info:
/var/log/ from the host

Comment 1 Simone Tiraboschi 2015-05-11 10:48:20 UTC
I think it's not FC specific, it happens also on iSCSI.

*** This bug has been marked as a duplicate of bug 1215623 ***


Note You need to log in before you can comment on or make changes to this bug.