Bug 1220226 - Chunk split failed when pushing big files (more than 1MiB)
Summary: Chunk split failed when pushing big files (more than 1MiB)
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Zanata
Classification: Retired
Component: Component-Persistence
Version: 3.7
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Damian Jansen
QA Contact: Zanata-QA Mailling List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-11 04:33 UTC by Ding-Yi Chen
Modified: 2015-07-29 02:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-29 02:09:22 UTC


Attachments (Terms of Use)
Step 5 server.log (36.20 KB, text/plain)
2015-05-11 04:33 UTC, Ding-Yi Chen
no flags Details
zanata.xml for project spacewalk (621 bytes, application/xml)
2015-05-11 05:38 UTC, Ding-Yi Chen
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1186972 0 high CLOSED RFE: Server-side file conversion and REST service 2021-02-22 00:41:40 UTC

Internal Links: 1186972

Description Ding-Yi Chen 2015-05-11 04:33:47 UTC
Created attachment 1024073 [details]
Step 5 server.log

Description of problem:
If file is more than 1MiB, the client will split files into chunks.
However, the push then failed when 
 1) --chunk-size was not specified
 2) files are bigger than what chunk specified.

Version-Release number of selected component (if applicable):
Zanata 3.7.0-SNAPSHOT (git-server-3.6.2-244-g5ba88b1)
Client: 3.7.0-SNAPSHOT (commit 62aa4858eb8a391540f217b27b5da52c0d2a77da)

How reproducible:
Always

Steps to Reproduce:
1. Clone the Spacework project: 
   git clone https://github.com/spacewalkproject/spacewalk.git/

2. Set up project spacework, version master 
3. Download the attached zanata.xml, and change the <url> to fit your environment
4. Run 
   zanata-cli -e push --file-types "GETTEXT,XLIFF"  --copy-trans false 
5. Run
   zanata-cli -e push --file-types "GETTEXT,XLIFF"  --copy-trans false --chunk-size 500000

Actual results:
Step 4. Failed with error as shown in 
   https://github.com/zanata/zanata-client/pull/57#issuecomment-99774102

Step 5. Failed with:

[INFO]         pushing chunk 1 of 3
Done in 0 secs
[INFO]         pushing chunk 2 of 3
[==   ][ERROR] Operation failed: POST http://dchen-t60.usersys.redhat.com:8080/zanata/rest/file/source/spacewalk/master?docId=java/code/src/com/redhat/rhn/frontend/strings/jsp/StringResource.xml returned a response status of 500 Internal Server Error
    To retry from the last document, please add the option: --from-doc "java/code/src/com/redhat/rhn/frontend/strings/jsp/StringResource.xml"
[ERROR] Execution failed: 
java.lang.RuntimeException: POST http://dchen-t60.usersys.redhat.com:8080/zanata/rest/file/source/spacewalk/master?docId=java/code/src/com/redhat/rhn/frontend/strings/jsp/StringResource.xml returned a response status of 500 Internal Server Error
        at org.zanata.client.commands.push.RawPushCommand.run(RawPushCommand.java:401)
        at org.zanata.client.commands.ConfigurableCommand.runWithActions(ConfigurableCommand.java:110)
        at org.zanata.client.commands.ArgsUtil.runCommand(ArgsUtil.java:48)
        at org.zanata.client.ZanataClient.processArgs(ZanataClient.java:170)
        at org.zanata.client.ZanataClient.main(ZanataClient.java:95)
Caused by: com.sun.jersey.api.client.UniformInterfaceException: POST http://dchen-t60.usersys.redhat.com:8080/zanata/rest/file/source/spacewalk/master?docId=java/code/src/com/redhat/rhn/frontend/strings/jsp/StringResource.xml returned a response status of 500 Internal Server Error
   
Expected results:
Both case work

Additional info:

Comment 1 Ding-Yi Chen 2015-05-11 05:38:00 UTC
Created attachment 1024083 [details]
zanata.xml for project spacewalk

Comment 2 Zanata Migrator 2015-07-29 02:09:22 UTC
Migrated; check JIRA for bug status: http://zanata.atlassian.net/browse/ZNTA-128


Note You need to log in before you can comment on or make changes to this bug.