Bug 122024 - Ant crashes with segmentation fault
Ant crashes with segmentation fault
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: ant (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Permaine Cheung
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-29 16:03 EDT by Rob Riggs
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:27:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Riggs 2004-04-29 16:03:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5)
Gecko/20031007

Description of problem:
Ant will not run.  It will always crash with a segmentation fault.

[robr@***** build]$ant
Segmentation fault


Version-Release number of selected component (if applicable):
ant-1.5.2-23

How reproducible:
Always

Steps to Reproduce:
1. run ant from command line
2. 
3.
    

Actual Results:  [robr@***** build]$ant
Segmentation fault

Expected Results:  Ant should run as classic-ant does:

[robr@***** build]$classic-ant
Buildfile: build.xml

init:
...

Additional info:
Comment 1 Gary Benson 2004-05-10 11:11:51 EDT
Could you try this with 1.5.2-26 please?
Comment 2 Rob Riggs 2004-06-01 21:31:54 EDT
1.5.2-26 does not appear to be available as an update for RHEL3.  I
assume you want me to try the FC1 package.  Will this work on EL3?

I can prevent the segfault in ant by removing the Oracle 8.1.7 Java
libraries from my CLASSPATH.  It seems to me that this is a problem
with ant, since I have not had any problems with other applications
with this CLASSPATH.
Comment 3 RHEL Product and Program Management 2007-10-19 15:27:07 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.