Bug 1220322 - When launch virt-manager with option "--show-host-summary", connection details window comes several times
Summary: When launch virt-manager with option "--show-host-summary", connection detail...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager
Version: 7.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Giuseppe Scrivano
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-11 10:12 UTC by zhoujunqin
Modified: 2015-11-19 05:26 UTC (History)
4 users (show)

Fixed In Version: virt-manager-1.2.0-3-el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 05:26:02 UTC
Target Upstream Version:


Attachments (Terms of Use)
virt-manager debug log (285.26 KB, text/plain)
2015-05-11 10:12 UTC, zhoujunqin
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2206 0 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2015-11-19 08:17:29 UTC

Description zhoujunqin 2015-05-11 10:12:42 UTC
Created attachment 1024182 [details]
virt-manager debug log

Description of problem:
When launch virt-manager with option "--show-host-summary", several connection details windows comes

Version-Release number of selected component (if applicable):
virt-manager-1.2.0-2.el7.noarch
libvirt-1.2.15-1.el7.x86_64
qemu-kvm-rhev-2.3.0-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Launch  virt-manager with option " --show-host-summary" to show connection details window
# virt-manager --show-host-summary -c qemu:///system

Actual results:
About 31 connection details windows comes out

Expected results:
Only 1 connection details windows comes out.

Additional info:
I will attach virt-manager debug information.

Comment 2 Giuseppe Scrivano 2015-05-11 13:31:37 UTC
patch proposed upstream: https://www.redhat.com/archives/virt-tools-list/2015-May/msg00030.html

Comment 5 fwu 2015-05-27 08:51:55 UTC
I can reproduce this bug with package:
virt-manager-1.2.0-2.el7.noarch

Steps are the same as description above.

Then try to verify with new build:
virt-manager-1.2.0-4.el7.noarch

Step:
1.Launch virt-manager with option " --show-host-summary" to show connection details window:
# virt-manager --show-host-summary -c qemu:///system

Result:
After Step 1, only 1 connection details windows comes out.

According to the result above in the latest version of virt-manager, move this bug from ON_QA to VERIFIED.

Comment 7 errata-xmlrpc 2015-11-19 05:26:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2206.html


Note You need to log in before you can comment on or make changes to this bug.