Bug 1220348 - Client hung up on listing the files on a perticular directory
Summary: Client hung up on listing the files on a perticular directory
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1230350
TreeView+ depends on / blocked
 
Reported: 2015-05-11 11:54 UTC by RajeshReddy
Modified: 2016-07-13 22:35 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1224160 1230350 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:00:02 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description RajeshReddy 2015-05-11 11:54:04 UTC
Description of problem:
=================================
Client hung up on listing the files on a perticular directory and not able to list the files in the directory 


Version-Release number of selected component (if applicable):
===============================================================
glusterfs-server-3.7.0beta1-0.69.git1a32479.el6.x86_64

How reproducible:


Steps to Reproduce:
======================
1.Create (4+2) disperse volume and enable bitrot on the volume and mount it on client (FUSE)
2.Using DD create 10k files on mount and while script is running bring down three bricks and after that file creation failed on client 
3.Try to list the files of the directory in the client (Evern after re-mount) client hung up

Actual results:
===================
User should be able to list the list of files and read it 

Expected results:


Additional info:

Comment 1 Anand Avati 2015-06-10 06:56:49 UTC
REVIEW: http://review.gluster.org/11152 (cluster/ec: Wind unlock fops at all cost) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 2 Anand Avati 2015-06-11 06:37:17 UTC
COMMIT: http://review.gluster.org/11152 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 5c00a6c8163cc255e777823b99d516dfb5ef114e
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Wed Jun 10 10:30:03 2015 +0530

    cluster/ec: Wind unlock fops at all cost
    
    Problem:
    While files are being created if more than redundancy number of bricks
    go down, then unlock for these fops do not go to the bricks. This will
    lead to stale locks leading to hangs.
    
    Fix:
    Wind unlock fops at all costs.
    
    Change-Id: I50a87e8b4d6d2dde5bf7405b82e3aeecd95ad00e
    BUG: 1220348
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/11152
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Xavier Hernandez <xhernandez@datalab.es>

Comment 3 Mike McCune 2016-03-28 23:18:47 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 4 Niels de Vos 2016-06-16 13:00:02 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.