Bug 1220349 - gvfs-open doesn't work
Summary: gvfs-open doesn't work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gvfs
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ondrej Holy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-11 11:54 UTC by Matej Habrnal
Modified: 2015-06-21 00:10 UTC (History)
8 users (show)

Fixed In Version: gvfs-1.24.1-2.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-21 00:10:07 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 746534 0 None None None Never

Description Matej Habrnal 2015-05-11 11:54:18 UTC
Description of problem:
When I run '$ gvfs-open DIR', nothing happens almost every time. Nautilus opened the DIR only if I run the command N times (where N is 10-100).

I tried it on liveCD Fedora-Live-Workstation-x86_64-22_Beta-3.iso and it didn't work well too.

Version-Release number of selected component (if applicable):
gvfs-1.24.0-1.fc22.x86_64

How reproducible:
almost every time

Steps to Reproduce:
1. Run Fedora 22 from LiveCD
2. Run '$ gvfs-open DIR'

Actual results:
DIR is not opened

Expected results:
DIR is opened by Nautilus

Additional info:
$ gvfs-info Music/
display name: Music
edit name: Music
name: Music
type: directory
size:  4096
uri: file:///home/mhabrnal/Music
attributes:
  standard::type: 2
  standard::name: Music
  standard::display-name: Music
  standard::edit-name: Music
  standard::copy-name: Music
  standard::icon: folder-music, folder
  standard::content-type: inode/directory
  standard::fast-content-type: inode/directory
  standard::size: 4096
  standard::allocated-size: 4096
  standard::symbolic-icon: folder-music-symbolic, folder-symbolic, folder-music, folder
  etag::value: 1426234731:422934
  id::file: l64768:125
  id::filesystem: l64768
  access::can-read: TRUE
  access::can-write: TRUE
  access::can-execute: TRUE
  access::can-delete: TRUE
  access::can-trash: TRUE
  access::can-rename: TRUE
  time::modified: 1426234731
  time::modified-usec: 422934
  time::access: 1431000137
  time::access-usec: 856282
  time::changed: 1426234731
  time::changed-usec: 422934
  unix::device: 64768
  unix::inode: 125
  unix::mode: 16877
  unix::nlink: 2
  unix::uid: 1000
  unix::gid: 1000
  unix::rdev: 0
  unix::block-size: 4096
  unix::blocks: 8
  owner::user: mhabrnal
  owner::user-real: mhabrnal
  owner::group: mhabrnal
  selinux::context: unconfined_u:object_r:audio_home_t:s0
  xattr-sys::security.selinux: unconfined_u:object_r:audio_home_t:s0

$ gvfs-mime --query inode/directory
Default application for 'inode/directory': org.gnome.Nautilus.desktop
Registered applications:
	org.gnome.Nautilus.desktop
	org.gnome.baobab.desktop
Recommended applications:
	org.gnome.Nautilus.desktop
	org.gnome.baobab.desktop

$ grep Exec /usr/share/applications/org.gnome.Nautilus.desktop
Exec=nautilus --new-window %U

Comment 1 Ondrej Holy 2015-05-11 12:05:34 UTC
Thanks for your bug report.

Actually this is glib bug, see the upstream bug report:
https://bugzilla.gnome.org/show_bug.cgi?id=746534

Comment 2 Ondrej Holy 2015-06-12 06:48:18 UTC
The workaround for gvfs-open has been pushed upstream yet.

Comment 3 Fedora Update System 2015-06-12 07:42:50 UTC
gvfs-1.24.1-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/gvfs-1.24.1-2.fc22

Comment 4 lnie 2015-06-12 08:21:39 UTC
gvfs-1.24.1-2.fc22 works

Comment 5 Fedora Update System 2015-06-14 17:29:11 UTC
Package gvfs-1.24.1-2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gvfs-1.24.1-2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-9959/gvfs-1.24.1-2.fc22
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2015-06-21 00:10:07 UTC
gvfs-1.24.1-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.