Bug 1220679 - Disable SSL3 and RC4 by default
Summary: Disable SSL3 and RC4 by default
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Changes Tracking
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Kurik
QA Contact:
Sandra McCann
URL:
Whiteboard: ChangeAcceptedF23, SystemWideChange
Keywords:
: 1166526 (view as bug list)
Depends On:
Blocks: 1166571
TreeView+ depends on / blocked
 
Reported: 2015-05-12 08:00 UTC by Jan Kurik
Modified: 2016-09-29 11:25 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-09-29 11:25:40 UTC


Attachments (Terms of Use)

Description Jan Kurik 2015-05-12 08:00:31 UTC
This is a tracking bug for Change: Disable SSL3 and RC4 by default
For more details, see: https://fedoraproject.org//wiki/Changes/RemoveSSL3andRc4

This change will disable by default the SSL 3.0 protocol and the RC4 cipher in components which use the system wide crypto policy. That is, gnutls and openssl libraries, and all the applications based on them.

Comment 1 Nikos Mavrogiannopoulos 2015-05-28 13:57:19 UTC
*** Bug 1166526 has been marked as a duplicate of this bug. ***

Comment 2 Jan Kurik 2015-07-14 14:02:47 UTC
This message is a reminder that Fedora 23 Change Checkpoint: Completion deadline (testable) is on 2015-07-28 [1].

At this point, all accepted Changes should be substantially complete, and testable. Additionally, if a change is to be enabled by default, it must be so enabled at Change Completion deadline.

This bug should be set at least to the MODIFIED state to indicate that it achieved completeness. Status will be provided to FESCo right after the deadline. If, for any reasons, your Change is not in required state, let me know and we will try to find solution. For Changes you decide to cancel/move to the next release, please use the NEW status and set needinfo on me and it will be acted upon. 

In case of any questions, don't hesitate to ask Wrangler (jkurik). Thank you.

[1] https://fedoraproject.org/wiki/Releases/23/Schedule

Comment 3 Sandra McCann 2015-08-25 13:45:00 UTC
Draft release note available at:
https://fedoraproject.org/wiki/Documentation_Security_Beat

Comment 4 Jan Kurik 2015-09-01 14:54:22 UTC
This message is a reminder that Fedora 23 Change Checkpoint: 100% Code Complete Deadline is on 2015-Sep-08 [1].

Expected bug state is ON_QA - Change has to be code complete and is possible to test it in the Beta release.

Status will be provided to FESCo right after the deadline. If, for any reasons, your Change is not in required state, let me know and we will try to find solution.  It's important milestone as contingency plan may be put into effect if the Change that miss this deadline.

In case of any questions, don't hesitate to ask Wrangler (jkurik). Thank you.

[1] https://fedoraproject.org/wiki/Releases/23/Schedule


Note You need to log in before you can comment on or make changes to this bug.