Bug 1220821 - dnf - joystick-support - kernel-[debug]
Summary: dnf - joystick-support - kernel-[debug]
Keywords:
Status: CLOSED DUPLICATE of bug 1192189
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 22
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-12 14:22 UTC by poma
Modified: 2015-05-13 10:11 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-13 09:42:03 UTC


Attachments (Terms of Use)

Description poma 2015-05-12 14:22:28 UTC
Fedora-Live-Xfce-x86_64-rawhide-20150512.iso


# rpm -qa | grep ^kernel
kernel-4.1.0-0.rc3.git0.1.fc23.x86_64
kernel-core-4.1.0-0.rc3.git0.1.fc23.x86_64
kernel-modules-4.1.0-0.rc3.git0.1.fc23.x86_64


# dnf --version
1.0.0
  Installed: dnf-0:1.0.0-1.fc23.noarch at 2015-05-12 12:38
  Built    : Fedora Project at 2015-04-29 20:35

  Installed: rpm-0:4.12.0.1-14.fc23.x86_64 at 2015-05-12 12:37
  Built    : Fedora Project at 2015-04-15 13:26


# dnf install joystick-support
Last metadata expiration check performed 0:02:32 ago on Tue May 12 10:15:50 2015.
Dependencies resolved.
================================================================================
 Package                 Arch      Version                     Repository  Size
================================================================================
Installing:
 joystick-support        noarch    1.0.0-13.fc21               rawhide    5.4 k
 kernel-core             x86_64    4.1.0-0.rc2.git3.1.fc23     rawhide     21 M
 kernel-modules          x86_64    4.1.0-0.rc2.git3.1.fc23     rawhide     18 M
 kernel-modules-extra    x86_64    4.1.0-0.rc2.git3.1.fc23     rawhide    2.3 M

Transaction Summary
================================================================================
Install  4 Packages

Total download size: 41 M
Installed size: 63 M
Is this ok [y/N]: 

# dnf --version
1.0.0
  Installed: dnf-0:1.0.0-1.fc23.noarch at 2015-05-12 12:38
  Built    : Fedora Project at 2015-04-29 20:35

  Installed: rpm-0:4.12.0.1-14.fc23.x86_64 at 2015-05-12 12:37
  Built    : Fedora Project at 2015-04-15 13:26

Comment 1 poma 2015-05-12 14:23:37 UTC
Follows Fedora 22 test ...

Comment 2 poma 2015-05-12 15:04:04 UTC
Fedora-Live-Xfce-x86_64-22-20150511.iso


# rpm -qa | grep ^kernel
kernel-4.0.1-300.fc22.x86_64
kernel-core-4.0.1-300.fc22.x86_64
kernel-modules-4.0.1-300.fc22.x86_64


# dnf --version1.0.0
  Installed: dnf-0:1.0.0-1.fc22.noarch at 2015-05-11 15:00
  Built    : Fedora Project at 2015-05-02 13:00

  Installed: rpm-0:4.12.0.1-9.fc22.x86_64 at 2015-05-11 14:59
  Built    : Fedora Project at 2015-04-15 09:21


# dnf install joystick-support
Last metadata expiration check performed 0:00:44 ago on Tue May 12 10:59:26 2015.
Dependencies resolved.
================================================================================
 Package                      Arch     Version          Repository         Size
================================================================================
Installing:
 joystick-support             noarch   1.0.0-13.fc21    fedora            5.4 k
 kernel-debug-core            x86_64   4.0.2-300.fc22   updates-testing    20 M
 kernel-debug-modules         x86_64   4.0.2-300.fc22   updates-testing    18 M
 kernel-debug-modules-extra   x86_64   4.0.2-300.fc22   updates-testing   2.3 M

Transaction Summary
================================================================================
Install  4 Packages

Total download size: 41 M
Installed size: 63 M
Is this ok [y/N]:

Comment 3 Michael Mráka 2015-05-13 08:19:37 UTC
Hello,
your bug report is incomplete and thus hard to understand what problem are you reporting. Please file thi missing information to the template bellow:

Description of problem:


Version-Release number of selected component (if applicable):
dnf-0:1.0.0-1.fc23.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 4 Hans de Goede 2015-05-13 08:33:33 UTC
(In reply to Michael Mráka from comment #3)
> Hello,
> your bug report is incomplete and thus hard to understand what problem are
> you reporting. Please file thi missing information to the template bellow:

On a rawhide system without kernel-modules-extra installed:

# dnf install joystick-support
Last metadata expiration check performed 0:02:32 ago on Tue May 12 10:15:50 2015.
Dependencies resolved.
================================================================================
 Package                 Arch      Version                     Repository  Size
================================================================================
Installing:
 joystick-support        noarch    1.0.0-13.fc21               rawhide    5.4 k
 kernel-core             x86_64    4.1.0-0.rc2.git3.1.fc23     rawhide     21 M
 kernel-modules          x86_64    4.1.0-0.rc2.git3.1.fc23     rawhide     18 M
 kernel-modules-extra    x86_64    4.1.0-0.rc2.git3.1.fc23     rawhide    2.3 M

This is the correct / desired behavior, note on a system where the kernel is fully up2date only kernel-modules-extra will be installed as extra dep.

On Fedora 22 OTOH:

# dnf install joystick-support
Last metadata expiration check performed 0:00:44 ago on Tue May 12 10:59:26 2015.
Dependencies resolved.
================================================================================
 Package                      Arch     Version          Repository         Size
================================================================================
Installing:
 joystick-support             noarch   1.0.0-13.fc21    fedora            5.4 k
 kernel-debug-core            x86_64   4.0.2-300.fc22   updates-testing    20 M
 kernel-debug-modules         x86_64   4.0.2-300.fc22   updates-testing    18 M
 kernel-debug-modules-extra   x86_64   4.0.2-300.fc22   updates-testing   2.3 M

dnf ends up installing kernel-debug-foo packages to satisfy the kernel module dependencies in the joystick-support, rather then kernel-modules-extra this is not desirable / not the expected behavior.

Comment 5 Radek Holy 2015-05-13 09:36:58 UTC
I understand that you think that it is obvious but can you please explain what rule do you think that DNF should use to do the "desired" decision? From its point of view, these are just two equal providers of the same missing virtual provide.

BTW, I think we can close this as a duplicate of 1192189 or some of the reports referred there.

Comment 6 Hans de Goede 2015-05-13 09:42:03 UTC
Hi,

(In reply to Radek Holy from comment #5)
> I understand that you think that it is obvious but can you please explain
> what rule do you think that DNF should use to do the "desired" decision?
> From its point of view, these are just two equal providers of the same
> missing virtual provide.

I don't see any clean solution here, I'm afraid that this will just need some special casing in the code where dnf hardcoded checks for kernel vs kernel-debug. An alternative would be to go with the package with the shortest name, which is what yum used to do IIRC.

> BTW, I think we can close this as a duplicate of 1192189 or some of the
> reports referred there.

I agree, marking this as a dup.

Regards,

Hans

*** This bug has been marked as a duplicate of bug 1192189 ***

Comment 7 Radek Holy 2015-05-13 09:59:42 UTC
Is it true that kernel-* packages are _always_ preferred to kernel-debug-* packages? If so, maybe it's another occurrence of a general problem of distributions' inability to express package preferences (https://bugzilla.redhat.com/show_bug.cgi?id=1149160#c29; just the first paragraph).

If kernel-* packages are preferred only by the joystick-support package, RPM's weak dependencies are the correct solution.

Comment 8 Hans de Goede 2015-05-13 10:11:01 UTC
(In reply to Radek Holy from comment #7)
> Is it true that kernel-* packages are _always_ preferred to kernel-debug-*
> packages? If so, maybe it's another occurrence of a general problem of
> distributions' inability to express package preferences
> (https://bugzilla.redhat.com/show_bug.cgi?id=1149160#c29; just the first
> paragraph).
> 
> If kernel-* packages are preferred only by the joystick-support package,
> RPM's weak dependencies are the correct solution.

I believe that it is fair to say that any package with a kernel-module requires wants the generic version of that module, not the debug version. As said, the rawhide behavior (which likely is a coincidence) is clearly the correct behavior here.


Note You need to log in before you can comment on or make changes to this bug.